uva 10014 Simple calculations(公式推导)

737 篇文章 0 订阅
109 篇文章 2 订阅

The Problem

There is a sequence of n+2 elements a0, a1,…, an+1 (n <= 3000; -1000 <=  ai 1000). It is known that ai = (ai–1 + ai+1)/2 – ci   for each i=1, 2, ..., n. You are given a0, an+1, c1, ... , cn. Write a program which calculates a1.

The Input

The first line is the number of test cases, followed by a blank line.

For each test case, the first line of an input file contains an integer n. The next two lines consist of numbers a0 and an+1 each having two digits after decimal point, and the next n lines contain numbers ci (also with two digits after decimal point), one number per line.

Each test case will be separated by a single line.

The Output

For each test case, the output file should contain a1 in the same format as a0 and an+1.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

1150.5025.5010.15

Sample Output

27.85

题目大意:给出一个数列的首项、 末项,和中间常量,根据公式ai = (ai–1 + ai+1)/2 – ci ,求a1项。

解题思路:公式可化简成ai  -   ai-1   = ai+1   -    ai     - 2 * ci,   ai+1 - ai = ai+2 - ai+1 - 2 *ci+1 就可以写成ai - ai-1 + 2 *ci = ai+2 - ai+1 -2 *ci+1, 列出所有项叠项项加后,可得n*(a1 - a0) = an+1 - a0  - sum    (sum可求)

#include<stdio.h>
#include<string.h>
#define N 3005
double a0, an, c[N], a1;
int n;

int main(){
	int t;
	scanf("%d", &t);
	while (t--){
		// Init.
		memset(c, 0, sizeof(c));

		// Read.
		scanf("%d", &n);
		scanf("%lf%lf", &a0, &an);
		for (int i = 1; i <= n; i++)
			scanf("%lf", &c[i]);

		double sum = 0;
		for (int i = 1; i <= n; i++)
			sum = sum + (n + 1 - i) * c[i];
		a1 = (an + n * a0 - 2 * sum) / (n + 1);
		printf("%.2lf\n", a1);
		if (t)
			printf("\n");
	}
	return 0;}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值