hud 2199 Can you solve this equation?(二分搜索)

582 篇文章 0 订阅
50 篇文章 0 订阅

Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input

       
       
2 100 -4
 

Sample Output

       
       
1.6152 No solution!
 

题目大意:根据题目所给定的公式,和后面给的一个Y值,在0~100的区间上求x的值。

解题思路:将公式求导可以证明曲线在0~100这个区间上是单调递增的,所以可以用二分搜索法去做,因为做这道题目的时候实在训练赛的时候,而且以前没有写过二分的题目,所以没想太多,直接写了一个递归的二分搜索,其实只要用一个whlie循环就可以搞定。

#include <stdio.h>
#include <math.h>

int t, y;

long long count(double x){
    double sum = 8 * pow(x, 4) + 7 * pow(x, 3) + 2 * pow(x, 2) + 3 * x + 6 - y;
   return floor(sum * 10000);
} 

void dfs(double a, double b){
    long long  x = count((a + b) / 2.0);
    
    if (x == 0)
	printf("%.4lf\n", (a + b) / 2.0);
    else if (x > 0)
	dfs(a, (a + b) / 2.0);
    else
	dfs((a + b) / 2.0, b);
}

int main(){
    scanf("%d", &t);
    while (t--){
	scanf("%d", &y);
	long long a = count(0);
	long long b = count(100);

	if (a == 0)
	    printf("0.0000\n");
	else if (b == 0)
	    printf("100.0000\n");
	else if (a > 0 && b < 0)
	    dfs(100, 0);
	else if (a < 0 && b > 0)
	    dfs(0, 100);
	else
	    printf("No solution!\n");
    }
    return 0;
}
    

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值