poj2184 Cow Exhibition(带负数的背包问题)(关于背包问题的精髓可以去百度背包九讲)

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7634 Accepted: 2775

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 
要两边的和都大于零,并且求出最大值,其实就是背包问题,只不过带了负数,取100000处为原点就可
Memory: 1488 KB Time: 141 MS Language: G++ Result:  Accepted
#include<stdio.h>

int c[1050],w[1050],f[201000];
#define A 1000000000
int main()
{
	int i,j,k,n,v,m,x,max;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<=200000;i++)
		{
			f[i]=-A;
		}//printf("%d ",w[0]);
		for(i=0;i<n;i++)
		{
			scanf("%d%d",c+i,w+i);
		}//printf("%d ",w[0]);
		
		f[100000]=0;
		for (i = 0; i < n; ++i)
		{
			if(c[i]<0&&w[i]<0)
				continue;
			if(c[i]>0)
			for (v = 200000; v >=c[i]; --v)//c[i]可优化为bound,bound = max {V - sum c[i,...n],c[i]}//正数的是从后往前的
			{
				if(f[v-c[i]]>-A)
				if(f[v] < f[v - c[i]] + w[i])
				{
					f[v] =f[v - c[i]] + w[i];
				}
			}
			else for (v = c[i];v<=200000+c[i]; v++)//注意啦,负数的递推方程是从前往后的,为的是避免重复加上一个状态
			{
				if(f[v-c[i]]>-A)
				if(f[v] < f[v - c[i]] + w[i])
				{
					f[v] =f[v - c[i]] + w[i];
				}
			}
			
		}
		max=-A;
		for(i=100000;i<=200000;i++)
		{
			if(f[i]>=0)
			{
				//printf("giuie");
				x=f[i]+i-100000;
				if(max<x)
					max=x;
			}
		}
		if(max!=-A)
			printf("%d\n",max);
		else printf("0\n");
	}
	return 0;
}

下面再贴一份学长写的16ms的程序,比我的快十倍啊

#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<stack>
#include<list>
#include<queue>
#define eps 1e-6
#define INF (1<<30)
#define PI acos(-1.0)
#define ll __int64
using namespace std;

int dp[210000]; //dp[i]表示当s的和为i-100000时,t的最大值
#define add 100000

int main()
{
   int n;

   while(scanf("%d",&n)!=EOF)
   {
      int s,t;
      int Max=0,Min=0;

      for(int i=0;i<=200000;i++)
         dp[i]=-INF;

      dp[add]=0;
      for(int i=1;i<=n;i++)
      {
         scanf("%d%d",&s,&t);
         if(s>0)//问题可能就出在这,他没有保存数组,而是输入一组数据就计算一下,可能时间就差在输入那个环节了,整体来看用的还是背包的思想
         {
            for(int i=Max+add;i>=Min+add;i--)
               dp[i+s]=max(dp[i+s],dp[i]+t);
            Max+=s;
         }
         else
         {
            for(int i=Min+add;i<=Max+add;i++)
               dp[i+s]=max(dp[i+s],dp[i]+t);
            Min+=s;
         }
      }
      int ans=0;

      for(int i=add;i<=Max+add;i++)
      {
         if(dp[i]>=0)
            ans=max(ans,i-add+dp[i]);
      }
      printf("%d\n",ans);


   }
   return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
众所周知,人工智能是当前最热门的话题之一, 计算机技术与互联网技术的快速发展更是将对人工智能的研究推向一个新的高潮。 人工智能是研究模拟和扩展人类智能的理论与方法及其应用的一门新兴技术科学。 作为人工智能核心研究领域之一的机器学习, 其研究动机是为了使计算机系统具有人的学习能力以实现人工智能。 那么, 什么是机器学习呢? 机器学习 (Machine Learning) 是对研究问题进行模型假设,利用计算机从训练数据中学习得到模型参数,并最终对数据进行预测和分析的一门学科。 机器学习的用途 机器学习是一种通用的数据处理技术,其包含了大量的学习算法。不同的学习算法在不同的行业及应用中能够表现出不同的性能和优势。目前,机器学习已成功地应用于下列领域: 互联网领域----语音识别、搜索引擎、语言翻译、垃圾邮件过滤、自然语言处理等 生物领域----基因序列分析、DNA 序列预测、蛋白质结构预测等 自动化领域----人脸识别、无人驾驶技术、图像处理、信号处理等 金融领域----证券市场分析、信用卡欺诈检测等 医学领域----疾病鉴别/诊断、流行病爆发预测等 刑侦领域----潜在犯罪识别与预测、模拟人工智能侦探等 新闻领域----新闻推荐系统等 游戏领域----游戏战略规划等 从上述所列举的应用可知,机器学习正在成为各行各业都会经常使用到的分析工具,尤其是在各领域数据量爆炸的今天,各行业都希望通过数据处理与分析手段,得到数据中有价值的信息,以便明确客户的需求和指引企业的发展。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值