POJ 1042 Gone Fishing(贪心+枚举)

Gone Fishing
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 26277 Accepted: 7740

Description

John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.

Output

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected.
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input

2 
1 
10 1 
2 5 
2 
4 
4 
10 15 20 17 
0 3 4 3 
1 2 3 
4 
4 
10 15 50 30 
0 3 4 3 
1 2 3 
0 

Sample Output

45, 5 
Number of fish expected: 31 

240, 0, 0, 0 
Number of fish expected: 480 

115, 10, 50, 35 
Number of fish expected: 724 

Source

 
题意:
有n个湖,每个湖有一个初始的每单位时间的上钩鱼数,在那里钓鱼时该上钩率会以di的速率不断下降,不钓的时候上钩率不变。这n个湖是排成一排的,从第一个湖开始每个单位时间可以选择钓鱼或者往下一个湖走,这些路是单向的不能往回走。给定总时间h,问最多能钓到多少鱼。
 
代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define N 27

int f[N],d[N],t[N],a[N][N],f1[N];
int n,h;

void init()
{
	memset(f,0,sizeof(f));
	memset(d,0,sizeof(d));
	memset(t,0,sizeof(t));
	memset(f1,0,sizeof(f1));
	memset(a,0,sizeof(a));
}

void input()
{
	int i;
	for(i=0;i<n;i++)
		scanf("%d",&f[i]);
	for(i=0;i<n;i++)
		scanf("%d",&d[i]);
	for(i=1;i<=n-1;i++)
		scanf("%d",&t[i]);
}

int main()
{
	int i,j,k;
	while(scanf("%d",&n)!=EOF && n!=0)
	{
		scanf("%d",&h);
		h*=12;          //以5分钟为单位
		
		init();         //初始化
		input();        //输入数据

		for(i=1;i<=n;i++)
		{
			int time,tmp=0;
			memcpy(f1,f,sizeof(f));
			h-=t[i-1];
			time=h;
			while(time>0 && tmp!=i)
			{
				k=0;
				for(j=1;j<i;j++)
					if(f1[j]>f1[k]) k=j;    //将能钓到鱼数最多的湖的下标赋给k
				
				a[i][0]+=f1[k];             //a[i][0]用来记录最远能走到第i湖时,能钓到的最多鱼数
				a[i][k+1]++;                //a[i][k+1]用来记录最远能走到第i湖时,在第k湖旁停留的次数,其中k为当前能钓到鱼数最多的湖
				time--;                     //时间单位减一
				if(f1[k]>0)
				{
					f1[k]-=d[k];            //5分钟后第k湖鱼量减少
					if(f1[k]<0) f1[k]=0;    //若鱼量为负,赋值为0
				}
				tmp=0;
				for(j=0;j<i;j++)
					if(f1[j]<0) tmp++;      //若tmp==i,则说明前i个湖中鱼都被钓完
			}
			a[i][1]+=time;                  //将剩余用时加至第一湖
		}
		
		k=1;
		for(j=2;j<=n;j++)
			if(a[j][0]>a[k][0]) k=j;        //寻找钓到鱼数的最大值
		for(j=1;j<=n;j++)
		{
			if(j!=1) printf(", ");
			printf("%d",a[k][j]*5);
		}
		printf("\n");
		printf("Number of fish expected: %d\n",a[k][0]);
		printf("\n");
	}
	return 0;
}


思路:
枚举最远能达到第i个湖时能钓到鱼的最大值,而每次钓鱼时选择能钓到鱼数最大的湖来钓。
每次循环时先减去路上所需时间,然后在几个湖之间的移动可看作瞬间转移。
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值