POJ 1141 Brackets Sequence

Brackets Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21978 Accepted: 6166 Special Judge

Description

Let us define a regular brackets sequence in the following way:

1. Empty sequence is a regular sequence.
2. If S is a regular sequence, then (S) and [S] are both regular sequences.
3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]

Source

 
题意:
给一组小括号与中括号的序列,添加最少的字符,使该序列变为合法序列,输出该合法序列。
 
代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define MAX 300

char str[MAX];
int dp[MAX][MAX],path[MAX][MAX];         //dp[i][j]用于记录字符串中第s位到第e位变成合法序列需添加多少个字符
                                                //path[i][j]用于记录字符串中第s位到第e位变成合法序列的改变路径
int len;

void init()
{
	int i;
	memset(dp,-1,sizeof(dp));
	memset(path,-1,sizeof(path));
	for(i=0;i<len;i++)
	{
		dp[i][i]=1;
		dp[i+1][i]=0;         
	}
}

bool match(char a,char b)
{
	if(a=='(' && b==')' || a=='[' && b==']') return true;
	else return false;
}

void output(int s,int e)
{
	if(s>e) return;
	else if(s==e)
	{
		if(str[s]=='(' || str[s]==')') printf("()");
		else printf("[]");
		return;
	}
	else if(path[s][e]==-1)
	{
		printf("%c",str[s]);
		output(s+1,e-1);
		printf("%c",str[e]);
		return;
	}
	else
	{
		output(s,path[s][e]);
		output(path[s][e]+1,e);
	}
}

int main()
{
	int i,j,s,e;

	while(gets(str)!=NULL)
	{
		len=strlen(str);
		init();

		for(i=1;i<len;i++)
		{
			for(j=0;j<len-i;j++)
			{
				s=j; e=j+i;
				if(match(str[s],str[e]))
					dp[s][e]=dp[s+1][e-1];                  //将dp[i+1][i]初始化为0的原因
				for(int k=s;k<e;k++)
				{
					if(dp[s][e]>dp[s][k]+dp[k+1][e] || dp[s][e]==-1)
					{
						dp[s][e]=dp[s][k]+dp[k+1][e];
						path[s][e]=k;
					}
				}
			}
		}
		output(0,len-1);
		printf("\n");
	}
	return 0;
}
 
思路:
dp[i][j]用于记录字符串中第s位到第e位变成合法序列需添加多少个字符
path[i][j]用于记录字符串中第s位到第e位变成合法序列的改变路径
状态转移方程:若str[s]与str[e]可搭配,则dp[s][e]=dp[s+1][e-1];否则,dp[s][e]=dp[s][k]+dp[k+1][e];(k从s到e)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值