POJ 2488 A Knight's Journey

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25252 Accepted: 8584

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany
 
题意:
给出国际象棋棋盘的行数和列数,判断马能不能不重复地走遍所有格子,若能,则按字典序输出走动路径
在国际象棋中马走“日”字格
 
代码:
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<string>
#define N 27

typedef struct Node
{
	int row,col;
}node;

node way[N*N];
int p,q;          //p为数字行,q为字母列
bool chess[N][N]; //每次查找时标记该位置有没有被走到过

int dx[8]={-1,1,-2,2,-2,2,-1,1};    //dfs时棋子走动顺序,注意顺序
int dy[8]={-2,-2,-1,-1,1,1,2,2};

bool dfs(int i,int j,int step)    //step为当前行走步数
{
	chess[i][j]=true;
	way[step].row=i;
	way[step].col=j;

	if(step==p*q) return true;   //step==p*q则所有格子都被走到

	for(int k=0;k<8;k++)
	{
		int ii=i+dx[k];
		int jj=j+dy[k];

		if(!chess[ii][jj] && ii>=1 && ii<=p && jj>='A' && jj<='A'+q-1)
			if(dfs(ii,jj,step+1))
				return true;
	}
	chess[i][j]=false;    //执行至此,前面8步均不能成立,返回上一层
	return false;
}

int main()
{
	int Case=1,t;

	while(scanf("%d",&t)!=EOF)
	{
		if(t==-1) break;
		while(t--)
		{
			memset(chess,false,sizeof(chess));
			scanf("%d%d",&p,&q);

			bool flag=false;

			for(int j='A';j<='A'+q-1;j++)
			{
				for(int i=1;i<=p;i++)
				{
					memset(way,0,sizeof(way));
					if(dfs(i,j,1))
					{
						printf("Scenario #%d:\n",Case++);
						for(int k=1;k<=p*q;k++)
							printf("%c%d",way[k].col,way[k].row);
						printf("\n\n");
						flag=true;
						break;
					}
				}
				if(flag) break;
			}
			if(!flag) 
			{
				printf("Scenario #%d:\n",Case++);
				printf("impossible\n\n");
			}
		}
	}
	return 0;
}

思路:
因为要求按字典序输出,则要注意深度搜索时的顺序
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值