POJ 1065 Wooden Sticks

Wooden Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16372 Accepted: 6794

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

Source

 
题意:
将不同长度和重量的木棍尽可能按两个属性的不下降序列排列,求其排列中的倒序数
 
代码:
#include<cstdio>
#include<cstring>
#include<cstdlib>
#define MAX 5002

typedef struct Stick
{
	int l,w;
};

Stick st[MAX];
int t,n;

int cmp(const void *a,const void *b)
{
	Stick *c=(Stick *)a,*d=(Stick *)b;
	if(c->l!=d->l) return c->l-d->l;
	else return c->w-d->w;
}

int main()
{
	int i,j,min;

	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d",&n);
			for(i=0;i<n;i++)
				scanf("%d%d",&st[i].l,&st[i].w);

			qsort(st,n,sizeof(struct Stick),cmp);
			
			min=0;
			for(i=0;i<n;i++)
			{
				int tmp=st[i].w;
				if(st[i].w)
				{
					min++;
					for(j=i+1;j<n;j++)
					{
						if(st[j].w>=tmp)
						{
							tmp=st[j].w;
							st[j].w=0;
						}
					}
				}
			}
			printf("%d\n",min);
		}
	}
	return 0;
}

思路:
求最少时间,本质为将一个属性按非降序排列后,看另一个属性排列尽可能少的倒序数。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值