POJ 2253 Frogger

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20762 Accepted: 6754

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

 
题意:
给出两个石头的坐标及其他n-2个石头的坐标,问要使一只青蛙能够跳到目标石头的最短青蛙跳跃距离是多少
 
代码:
/*Floyd*/

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#define MAX 202
using namespace std;

struct Point
{
	int x,y;
}a[MAX];
double path[MAX][MAX];    //path[i][j]存储由第i个石头能够跳到第j个石头的最短青蛙跳跃距离
						  //初始设为两石头的距离

int main()
{
	int Case=1;
	int n,i,j,k;
	while(scanf("%d",&n)!=EOF && n)
	{
		memset(path,0,sizeof(path));
		
		for(i=1;i<=n;i++)
			scanf("%d%d",&a[i].x,&a[i].y);

		for(i=1;i<n;i++)
			for(j=i+1;j<=n;j++)
			{
				double p=a[i].x-a[j].x;
				double q=a[i].y-a[j].y;
				path[i][j]=path[j][i]=sqrt(p*p+q*q);
			}

		for(k=1;k<=n;k++)
			for(i=1;i<=n;i++)
				for(j=1;j<=n;j++)
					if(path[i][k]<path[i][j] && path[k][j]<path[i][j])
						if(path[i][k]>path[k][j])
							path[i][j]=path[i][k];
						else 
							path[i][j]=path[k][j];

		printf("Scenario #%d\n",Case++);
		printf("Frog Distance = %.3f\n\n",path[1][2]);  //注意%.3f与%.3lf
	}
	return 0;
}

/*Dijkstra*/

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#define MAX 202
#define INF 0x3f3f3f3f
using namespace std;

bool vist[MAX];
double dis[MAX];
double map[MAX][MAX];     //map[i][j]存储由第i个石头能够跳到第j个石头的最短青蛙跳跃距离
						  //初始设为两石头的距离
struct Point
{
	int x,y;
}a[MAX];

int n;

double Dij(int m)
{
	for(int i=1;i<=n;i++)
		dis[i]=map[m][i];
	vist[m]=true;

	double min;
	int k;
	for(int i=0;i<n;i++)
	{
		min=INF;
		for(int j=1;j<=n;j++)
			if(!vist[j] && min>dis[j])
			{
				min=dis[j];
				k=j;
			}
		vist[k]=true;
		for(int j=1;j<=n;j++)
			if(!vist[j] && dis[j]>dis[k] && dis[j]>map[k][j])
			{
				if(dis[k]>map[k][j]) dis[j]=dis[k];
				else dis[j]=map[k][j];
			}
	}

	return dis[2];
}

int main()
{
	int Case=1;
	int i,j;

	while(scanf("%d",&n)!=EOF && n)
	{
		for(i=1;i<=n;i++)
			scanf("%d%d",&a[i].x,&a[i].y);

		memset(map,INF,sizeof(map));
		memset(dis,0,sizeof(dis));
		memset(vist,false,sizeof(vist));

		for(i=1;i<n;i++)
		{
			map[i][i]=0;
			for(j=i+1;j<=n;j++)
			{
				double p=a[i].x-a[j].x;
				double q=a[i].y-a[j].y;
				map[i][j]=map[j][i]=sqrt(p*p+q*q);
			}
		}

		double k=Dij(1);
		printf("Scenario #%d\n",Case++);
		printf("Frog Distance = %.3f\n\n",k);   //注意%.3f与%.3lf
	}
	return 0;
}

思路:
找出一条两两石头间距离尽可能短的路径中的最大石头间距即可
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值