POJ 1325 Machine Schedule

Machine Schedule
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10428 Accepted: 4414

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

Source

 
题意:
同一个任务可以在A,B两台不同的机器上以不同的模式完成.机器的初始模式是mode_0,但从任何模式改变成另一个模式需要重启机器.求完成所有工作所需最少重启次数
 
代码:
#include<iostream>
#include<string>
#include<cstring>
#include<cstdlib>
#include<cstdio>
#define MAX 102
using namespace std;

bool map[MAX][MAX];
bool vist[MAX];
int pre[MAX];
int n,m,k;

bool find(int cur)
{
	for(int i=1;i<=m;i++)
	{
		if(map[cur][i] && !vist[i])
		{
			vist[i]=true;
			if(pre[i]==-1 || find(pre[i]))
			{
				pre[i]=cur;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	while(scanf("%d",&n)!=EOF && n)
	{
		scanf("%d%d",&m,&k);
		memset(map,false,sizeof(map));
		memset(pre,-1,sizeof(pre));

		int x,y,z;
		for(int i=0;i<k;i++)
		{
			scanf("%d%d%d",&z,&x,&y);
			map[x][y]=true;
		}

		int ans=0;
		for(int i=1;i<=n;i++)
		{
			memset(vist,false,sizeof(vist));
			if(find(i)) ans++;
		}

		printf("%d\n",ans);
	}
	return 0;
}

思路:

对于任务(i,x,y),我们在A机mode_x与B机mode_y之间连一条边.这样,题目就变成了一个二分图,我们的目的是完成所有任务,即覆盖所有线段,题目要求选择最少的点,使得每个线段至少有一个端点被选中(这个任务就被完成了),这就是最小点覆盖模型,答案是这个二分图的最大匹配

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值