poj 1286 Necklace of Beads

Necklace of Beads
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6302 Accepted: 2628

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39


题目大意:就是有三种颜色给一窜珠子涂颜色,加上旋转和翻折出现相同的情况算一中。


又一道组合数学初级题目,就套用polya定理的公式就搞定了。哈哈,今天做的两题基本代码,基本思路都一样。


就分两大类考虑就完事,代码:



#include<iostream>
#include<fstream>
#include<iomanip>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<sstream>
#include<cassert>
using namespace std;
#define LL long long
LL gcd(LL a, LL b) {
    if(b == 0) return a;
    else return gcd(b, a % b);
}

LL polya(LL n) {
    LL ans=0;
    for(LL i=0; i<n; i++) {
        ans+=pow(3.0,gcd(i,n)+0.0);
    }
    if(n%2==1) {
        ans+=n*pow(3.0,(n+1)/2);
    } else {
        ans+=n/2*pow(3.0,n/2);
        ans+=n/2*pow(3.0,n/2+1);
    }
    return ans/n/2;

}

int main() {
    LL n;
    while(cin>>n) {
        if(n==-1)break;

        if(n<=0) {
            printf("0\n");
            continue;
        } else {
            printf("%lld\n",polya(n));
        }

    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值