acm线段树

Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input

 
   
1 10 2 1 5 2 5 9 3
 

Sample Output

 
   
Case 1: The total value of the hook is 24.



题目大意:
1 10 2 1 5 2 5 9 3
1表示测试样例数。
10表示测试范围,即开始时1—10内的树都为1。即建立树的大小!
2表示更新的范围数量。
1 5 2表示把1-5范围内的树更新成2
5   9   3 表示把5-9范围内的树更新成3
ans=2*4+3*5+1=24

分析:
此题是一道纯粹的线段树问题,一开始被题目吓着了。认为是一道很难的题目!在仔细看了一遍题之后,发现这就是一道简单的线段树!就是树的更新以及线段树的查询!
 
代码如下:
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <queue>
#include <cstdio>
#include <cmath>
#include <string>
#include <stack>
#define MAX 100005
using namespace std;
int sum[MAX<<2];
void pus(int N)
{
    sum[N]=(sum[N<<1]==sum[N<<1|1])?sum[N<<1]:-1;
}

//建立线段树

void build(int l,int r,int N)
{
    if(l==r)
    {
        sum[N]=1;
         return ;
    }
    int mid=(l+r)>>1;
    build(l,mid,N<<1);
    build(mid+1,r,N<<1|1);
    pus(N);
     return;
}

//更新线段树

void updata(int l,int r,int N,int p,int a,int b)
{
    if(a<=l&&r<=b)
    {
        sum[N]=p;
        return;
    }
    if(sum[N]>0)
        sum[N<<1]=sum[N<<1|1]=sum[N];
    int mid=(l+r)>>1;
    if(a<=mid&&sum[N<<1]!=p)
        updata(l,mid,N<<1,p,a,b);
    if(b>mid&&sum[N<<1|1]!=p)
        updata(mid+1,r,N<<1|1,p,a,b);
    pus(N);
}

//查询线段树
int query(int l,int r,int N,int a,int b)
{
    if(sum[N]>0)
        return sum[N]*(r-l+1);
    int mid=(l+r)>>1;
    int res=0;
    if(a<=mid)
        res+=query(l,mid,N<<1,a,b);
    if(b>mid)
        res+=query(mid+1,r,N<<1|1,a,b);
    return res;
}



int main()
{
    int T,n,q,a,b,p;
    scanf("%d",&T);
    for(int t=1; t<=T; ++t)
    {
        scanf("%d%d",&n,&q);
        build(1,n,1);

       
        while(q--)
        {
            scanf("%d%d%d",&a,&b,&p);
            updata(1,n,1,p,a,b);
        }


        printf("Case %d: The total value of the hook is %d.\n",t,query(1,n,1,1,n));

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值