VF

VF

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the  N th VF in the point  S is an amount of integers from 1 to  N that have the sum of digits  S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with  N = 10 9) >
输入
There are multiple test cases.
Integer S (1 ≤ S ≤ 81).
输出
The milliard VF value in the point S.
样例输入
1
样例输出
10
来源
USU Junior Championship March'2005
上传者

李文鑫


题意:1~1000000000之间,各位数字之和等于给定s的数的个数


1、只有s=1时,10^9的系数才能为1,否则就大于10^9;

所以和为1的要单一列出来。
2、如果s!=1:

定义状态dp[i][j]为前i位各位数之和为j的情况数量:对于前i为的数字之和最大为:9*i,即每一位数字都是9.


i=1、只有一位的数字,因为s>=1,所以最低位只能是1-9 其中的一个数字,


i>1、假设第i位放数字k(则k只能是0~9并且k<=s),若要使第前i位数字之和为j,那么前i-1位只能放j-k,由此得出动态转移方程:d[i]][j]=d[i][j]+d[i-1][j-k] (0<=k<=j&&k<=9)



#include<iostream>
#include<string.h>
using namespace std;
int dp[10][90];
int main()
{
	memset(dp,0,sizeof(dp));
	int i,j;
	for(i=1;i<10;++i)
	{
		for(j=1;j<10;++j)
		{
			dp[i][0]=1;
			dp[1][j]=1;
		}
	}
	for(i=2;i<10;++i)
	{
		for(j=1;j<82;++j)
		{
			for(int k=0;k<10;k++)
				if(j>=k)
					dp[i][j]+=dp[i-1][j-k];
		}
	}
	int n;
	while(cin>>n)
	{
		if(n==1)
			cout<<10<<endl;
		else
			cout<<dp[9][n]<<endl;
	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值