poj 1252完全背包 凑纸币

Euro Efficiency
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3085 Accepted: 1341

Description

On January 1st 2002, The Netherlands, and several other European countries abandoned their national currency in favour of the Euro. This changed the ease of paying, and not just internationally. 
A student buying a 68 guilder book before January 1st could pay for the book with one 50 guilder banknote and two 10 guilder banknotes, receiving two guilders in change. In short:50+10+10-1-1=68. Other ways of paying were: 50+25-5-1-1, or 100-25-5-1-1.Either way, there are always 5 units (banknotes or coins) involved in the payment process, and it 
could not be done with less than 5 units. 
Buying a 68 Euro book is easier these days: 50+20-2 = 68, so only 3 units are involved.This is no coincidence; in many other cases paying with euros is more efficient than paying with guilders. On average the Euro is more efficient. This has nothing to do, of course, with the value of the Euro, but with the units chosen. The units for guilders used to be: 1, 2.5, 5, 10, 25, 50,whereas the units for the Euro are: 1, 2, 5, 10, 20, 50. 
For this problem we restrict ourselves to amounts up to 100 cents. The Euro has coins with values 1, 2, 5, 10, 20, 50 eurocents. In paying an arbitrary amount in the range [1, 100] eurocents, on average 2.96 coins are involved, either as payment or as change. The Euro series is not optimal in this sense. With coins 1, 24, 34, 39, 46, 50 an amount of 68 cents can be paid using two coins.The average number of coins involved in paying an amount in the range [1, 100] is 2.52. 
Calculations with the latter series are more complex, however. That is, mental calculations.These calculations could easily be programmed in any mobile phone, which nearly everybody carries around nowadays. Preparing for the future, a committee of the European Central Bank is studying the efficiency of series of coins, to find the most efficient series for amounts up to 100 eurocents. They need your help. 
Write a program that, given a series of coins, calculates the average and maximum number of coins needed to pay any amount up to and including 100 cents. You may assume that both parties involved have sufficient numbers of any coin at their disposal. 

Input

The first line of the input contains the number of test cases. Each test case is described by 6 different positive integers on a single line: the values of the coins, in ascending order. The first number is always 1. The last number is less than 100. 

Output

For each test case the output is a single line containing first the average and then the maximum number of coins involved in paying an amount in the range [1, 100]. These values are separated by a space. As in the example, the average should always contain two digits behind the decimal point. The maximum is always an integer. 

Sample Input

3
1 2 5 10 20 50
1 24 34 39 46 50
1 2 3 7 19 72

Sample Output

2.96 5
2.52 3
2.80 4
 
/*
题目:
	给出六种不同的纸币面额,求用最少的纸币数量凑出1-100的钱数,
求平均需要纸币数量 和 最大纸币数量
解题思路:
		先求相加可得1-100的钱,dp[i]表示 凑出i块钱所需最少的纸
		币数量,此题中必然为恰好凑出来,所以注意初始化,这里是
		求最小的解,而普通完全背包是求最大解,所以初始化的时候
		恰恰相反,dp[i]需要初始化为一个比较大的一个数;
		这里等同于背包最大容量的值可以看成是100*100,因为100块
		钱最多这六种都是1块的,每种都有100中方法,所以为100*100
*/
#include<iostream>
#include<cstring>
#include<algorithm>
#include<iomanip>
using namespace std;
#define N 10000
int dp[N];
int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		int w[7],i,j;
		for(i=1;i<=6;++i)
			cin>>w[i];
		fill(dp+1,dp+N+1,10*N);
		dp[0]=0;
		for(i=1;i<=6;++i) //考虑每种币值可以进行"加"运算 
			              //(这是传统的完全背包问题)
         
		{
			for(j=w[i];j<=N;++j)
			{
				dp[j]=min(dp[j],dp[j-w[i]]+1);
			}
		}
		for(i=1;i<=6;++i)//考虑每种币值可以进行"减"运算 
						 //(这是一个小扩展——“可以找零 ”)  
		{
			for(j=N;j>=0;--j)
			{
				dp[j]=min(dp[j],dp[j+w[i]]+1);
			}
		}
		double sum=0;
		int max_num=0;
		for(i=1;i<=100;++i)
		{
			sum+=dp[i];
			max_num=max(dp[i],max_num);
		}

		cout<<setiosflags(ios::fixed)<<setprecision(2)<<sum/100<<' ';
		cout<<max_num<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值