poj 3254 Corn Fields

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6569 Accepted: 3498

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;  
int dp[20][600];  //dp[i][j]表示第i行第j个状态所能达到的最大方案数目。
				//状态转移:dp[i][j] += dp[i-1][k]
int map[20],state[600];
int most;
bool cmp(int a,int b)
{
	if((a&b)==0)
		return true;
	return false;
}
void findstate(int n)
{
	int i;
	int num=1<<n;
	most=0;
	for(i=0;i<num;++i)     //初始时找出所有的可能的(合法的)状态
	{
		if((i&(i<<1))==0)  
			state[++most]=i;
	}
}
int main()
{
	int m,n,i,j;
	while(cin>>m>>n)
	{
		memset(dp,0,sizeof(dp));  
		memset(state,0,sizeof(state));  
		memset(map,0,sizeof(map));  

		char temp;
		findstate(n);
		for(i=1;i<=m;++i)
		{
			for(j=1;j<=n;++j)
			{
				cin>>temp;
				if(temp=='0')
					map[i]+=(1<<(n-j));
			}
		}

		for(i=1;i<=most;++i)  //处理第一行炮兵放置情况 
		{
			if(cmp(map[1],state[i]))
				dp[1][i]=1;  //若第1行的状态与第i种可行状态吻合,则dp[1][i]记为1  
		}


		for(i=2;i<=m;++i)
		{
			for(int j=1;j<=most;++j)//当第i行取第j种状态  
			{  
				if(!cmp(state[j],map[i]))  continue;//若j与实际情况冲突  

				for(int k=1;k<=most;++k)//第i-1行取第k种状态  
				{  
					if(!cmp(state[j],state[k]))    continue;//若k与j冲突  
					if(!cmp(state[k],map[i-1]))    continue;//i-1行不能与k冲突  

					dp[i][j]=(dp[i][j]+dp[i-1][k])%100000000;  
				}  
			}  
		} 
		int ans=0; 
		for(i=1;i<=most;++i)
			ans=(ans+dp[m][i])%100000000;

		cout<<ans<<endl;  
	}  
	return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值