hdu 1520 Anniversary party

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4324    Accepted Submission(s): 1984


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
  
  
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
  
  
5
 
这道题可以简单的描述为有一些数据之间有父子关系,现在需要选择一些数据出来,使数据总的和最大,但要求数据两两之间不能有直接的父子关系。若设节点i为某一个根,则可以设dp[i][0]表示不包括i的子树的最大和,dp[i][1]表示包括节点i的子树的最大和。则最终所求的结果为:
ans=max{dp[i][0],dp[i][1]}

dp[i][0]=sum(max{dp[j][0],dp[j][1]}) //如果不包括i,则其子树的最大和是不包括其孩子

        //或者包括其孩子两种可能下的最大和

dp[i][1]=sum(dp[j][0]) //如果包括i,则只能是不包括其孩子的最大和

#include<iostream>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 6005
int dp[N][2],v[N];
vector<int> map[N];
bool noboss[N];

int dfs(int boss,int c)
{
	if(dp[boss][c]>0)
		return dp[boss][c];
	if(map[boss].size()==0)
	{
		if(c==1)
			return dp[boss][c]=v[boss];
		else
			return dp[boss][c]=0;
	}
	if(c==1)
	{
		dp[boss][c]=v[boss];
		int temp=0;
		for(int i=0;i<map[boss].size();++i)
			temp+=dfs(map[boss][i],0);
		dp[boss][c]+=temp;
	}
	if(c==0)
	{
		int temp=0,temp1,temp2;;
		for(int i=0;i<map[boss].size();++i)
		{
			temp1=dfs(map[boss][i],0);
			temp2=dfs(map[boss][i],1);
			temp+=max(temp1,temp2);
		}
		dp[boss][c]+=temp;
	}
	return dp[boss][c];
}
int main()
{
	int n;
	while(cin>>n)
	{
		for(int i=1;i<=n;++i)
			cin>>v[i];
		for(int i=0;i<=n;++i)
			map[i].clear();
		memset(noboss,0,sizeof(noboss));
		memset(dp,0,sizeof(dp));
		int a,b,boss;
		while(1)
		{
			cin>>a>>b;
			if(a+b==0)
				break;
			map[b].push_back(a);
			noboss[a]=1;
		}
		for(int i=1;i<=n;++i)
		{
			if(noboss[i]==0)
			{
				boss=i;
				break;
			}
		}
		int ans1,ans2;
		ans1=dfs(boss,1);
		ans2=dfs(boss,0);
		cout<<max(ans1,ans2)<<endl;
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值