hdu1097

Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
  
  
7 66 8 800
 

Sample Output
  
  
9 6
 
 
寻找规律。除了0,1,5,6不改变后面数字,4,9两次一循环,其余的都是4次一循环。

#include<stdio.h>
int main()
{
    int a,b,s,i,k;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        if(a%10==0) printf("0\n");
        if(a%10==1) printf("1\n");
        if(a%10==2)
        {
            if(b%4==0) printf("6\n");
            if(b%4==1) printf("2\n");
            if(b%4==2) printf("4\n");
            if(b%4==3) printf("8\n");
        }
        if(a%10==3)
        {
            if(b%4==0) printf("1\n");
            if(b%4==1) printf("3\n");
            if(b%4==2) printf("9\n");
            if(b%4==3) printf("7\n");
        }
        if(a%10==4)
        {
            if(b%2==0) printf("6\n");
            else printf("4\n");
        }
        if(a%10==5) printf("5\n");
        if(a%10==6) printf("6\n");
        if(a%10==7)
        {
            if(b%4==0) printf("1\n");
            if(b%4==1) printf("7\n");
            if(b%4==2) printf("9\n");
            if(b%4==3) printf("3\n");
        }
        if(a%10==8)
        {
            if(b%4==0) printf("6\n");
            if(b%4==1) printf("8\n");
            if(b%4==2) printf("4\n");
            if(b%4==3) printf("2\n");
        }
        if(a%10==9)
        {
            if(b%2==0) printf("1\n");
            else printf("9\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值