The number of steps

Description

Mary stands in a strange maze, the maze looks like a triangle(the first layer have one room,the second layer have two rooms,the third layer have three rooms …). Now she stands at the top point(the first layer), and the KEY of this maze is in the lowest layer’s leftmost room. Known that each room can only access to its left room and lower left and lower right rooms .If a room doesn’t have its left room, the probability of going to the lower left room and lower right room are a and b (a + b = 1 ). If a room only has it’s left room, the probability of going to the room is 1. If a room has its lower left, lower right rooms and its left room, the probability of going to each room are c, d, e (c + d + e = 1). Now , Mary wants to know how many steps she needs to reach the KEY. Dear friend, can you tell Mary the expected number of steps required to reach the KEY?

Input

There are no more than 70 test cases.

In each case , first Input a positive integer n(0<n<45), which means the layer of the maze, then Input five real number a, b, c, d, e. (0<=a,b,c,d,e<=1, a+b=1, c+d+e=1).

The input is terminated with 0. This test case is not to be processed.

Output

Please calculate the expected number of steps required to reach the KEY room, there are 2 digits after the decimal point.

Sample Input

30.3 0.70.1 0.3 0.60

Sample Output

3.41
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
     int n;
     double dp[150][150];
     double a,b,c,d,e;
     while(scanf("%d",&n)&&n)
     {
         scanf("%lf%lf%lf%lf%lf",&a,&b,&c,&d,&e);
         memset(dp,0,sizeof(dp));
         dp[n][n]=0;
         for(int j=n-1;j>=1;j--)
         dp[n][j]+=1*(dp[n][j+1]+1);//初始化最后一行
         for(int i=n-1;i>=1;i--)
         {
             dp[i][i]+=a*(dp[i+1][i+1]+1)+b*(dp[i+1][i]+1);//初始化最左边的房间
             for(int j=i-1;j>=1;j--)
             dp[i][j]+=c*(dp[i+1][j+1]+1)+d*(dp[i+1][j]+1)+e*(dp[i][j+1]+1);//初始化其他房间
         }
         printf("%.2lf\n",dp[1][1]);
     }
     return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值