hdu 1671 字典序问题

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8521    Accepted Submission(s): 2901


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1075  1247  1677  1298  2846 








对于这个题目我本人表示比较无语,因为我采用了各种方式,都不由得的超时了,我采用了strstr的函数判断,不得不超时了,后来改kmp,还是超时,用vector,先排下序,然后用find函数进行判断,结果还是悲催的超时了,我得出了一个结论,对于此题而言是不能是挨个比较的,必须建好字典树,然后在查一下是否存在那种有的,就好了。查找函数比较有水平.

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
struct TrieNode
{
  int cnt;
  TrieNode* next[10];
  TrieNode()
  {
    cnt=0;
    memset(next,0,sizeof(next));
  }
};

TrieNode* root=new TrieNode;

void build(char* s)
{
    TrieNode* p=root;
    int len=strlen(s);
    for(int i=0;i<len;i++)
    {
        if(!p->next[s[i]-'0'])
        p->next[s[i]-'0']=new TrieNode;
        p=p->next[s[i]-'0'];
        p->cnt++;
    }
}

int Search(char* s)
{
    TrieNode* p=root;
    int len=strlen(s);
    for(int i=0;i<len;i++)
        p=p->next[s[i]-'0'];
    return p->cnt;
}

void Del(TrieNode* p)
{
    for(int i=0;i<10;i++)
    {
        if(p->next[i]!=NULL)
            Del(p->next[i]);
    }
    free(p);
}
int main()
{
    int t,n,i;
    char str[10001][30];
    scanf("%d",&t);
    while(t--)
    {
        root=new TrieNode;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%s",str[i]);
            build(str[i]);
        }
        //建立字典树
        int flag=1;

        for(i=0;i<n;i++)
        {
            if(Search(str[i])!=1)
            {
                flag=0;
                break;
            }
        }
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
        Del(root);//递归的释放内存

    }
   return 0;
}









 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值