【POJ】[2251]Dungeon Master

Dungeon Master

Time Limit: 1000MSMemory Limit: 65536K

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). L is the number of levels making up the dungeon. R and C are the number of rows and columns making up the plan of each level. Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).
where x is replaced by the shortest time it takes to escape. If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

三维BFS,不算难题 这一题数据给的非常严 DFS必然超时 (不是很喜欢POJ这样子-.-) 注意标记已遍历要放在push前 否则也会把一个点加入队列多次 导致内存超限或者时间超限 -.-就是这么严
#include<cstdio>
#include<queue>
using namespace std;
int movet[6]= {0,0,0,0,1,-1};
char map[32][32][32];
bool flag[32][32][32];
struct node {
    int l,r,c,cnt;
} t,temp;
int L,R,C;
int sl,sr,sc;
int el,er,ec;
int bfs() {
    queue<node>q;
    t.l=sl,t.r=sr,t.c=sc,t.cnt=0;
    flag[t.l][t.r][t.c]=true;
    q.push(t);
    while(!q.empty()) {
        t=q.front();
        for(int i=0; i<6; i++) {
            temp.l=t.l+movet[i],temp.r=t.r+movet[(i+2)%6],temp.c=t.c+movet[(i+4)%6],temp.cnt=t.cnt+1;
            if(temp.l==el&&temp.r==er&&temp.c==ec)
                return temp.cnt;
            else if(temp.l>=0&&temp.l<L&&temp.r>=0&&temp.r<R&&temp.c>=0&&temp.c<C&&map[temp.l][temp.r][temp.c]!='#'&&!flag[temp.l][temp.r][temp.c]) {
                flag[temp.l][temp.r][temp.c]=true;
                q.push(temp);
            }
        }
        q.pop();
    }
    return -1;
}
int main() {
    while(scanf("%d %d %d",&L,&R,&C),L&&R&&C) {
        getchar();
        for(int i=0; i<L; i++) {
            for(int j=0; j<R; j++) {
                for(int k=0; k<C; k++) {
                    flag[i][j][k]=false;
                    scanf("%c",&map[i][j][k]);
                    if(map[i][j][k]=='S')
                        sl=i,sr=j,sc=k;
                    else if(map[i][j][k]=='E')
                        el=i,er=j,ec=k;
                }
                getchar();
            }
            getchar();
        }
        int res=bfs();
        if(res<0)
            printf("Trapped!\n");
        else
            printf("Escaped in %d minute(s).\n",res);
    }
    return 0;
}

题目地址: 【POJ】[2251]Dungeon Master


查看原文:http://www.boiltask.com/blog/?p=1913
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值