HDU--1610 -- Count the Colors [线段树是也]

 

Count the Colors

 

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1

 

Code:

 

委屈开始题意理解错了... 还以为是让数每个小段的相同颜色的个数...

原来是如果两个相同颜色的段是相邻的,那么就合成一段了...

晕的还以为题上sample output 给错了

先附上白痴代码, 以备日后面壁!

怀疑题出错了是要付出代价的!哭

 

#include"stdio.h"

int main()
{
	int tree[8010];
	int finalcolor[8010];
	int n,i,j;
	int ls,rs,c;//临时的表示当前输入数据的左右范围及颜色 
	int rmax;//表示总的最右边界 
	while(scanf("%d",&n)!=EOF)
	{
		rmax = 0;
		for(i=0;i<n;i++)//输入n个颜色,及其染色范围 
		{
			scanf("%d%d%d",&ls,&rs,&c);
			if(rs>rmax) rmax = rs;//从1开始的下标中存放的值表示前面一单位段的颜色 
			for(j=ls+1;j<=rs;j++)//后来输入的颜色会直接覆盖前面的颜色 
				tree[j] = c;			
		}
		
	//	for(i=1;i<=rmax;i++)
	//		printf("%d ",tree[i]);
	//	printf("\n-----\n");
		
		for(i=0;i<=rmax;i++)//初始化,将颜色为i的段数全部赋值为0 
			finalcolor[i] = 0;
			//finalcolor[i].sign = finalcolor[i].num = 0;
			 	
		int k;
		j=0;
		for(i=1;i<=rmax;i++)
		{		 
			finalcolor[tree[i]]++;
						
		}//for
		
		for(i=0;i<=rmax;i++)
		{
			if(finalcolor[i])
				printf("%d %d\n",i,finalcolor[i]);
		} 
		
	}//while
	return 0;
}


 

下面是正确AC的code,

这次也算是理解了线段树的合并属性~~.....

 

#include"stdio.h"
#include"string.h"
int main()
{
	int tree[8010];
	int finalcolor[8010];
	int n,i,j;
	int ls,rs,c;//临时的表示当前输入数据的左右范围及颜色 
	int rmax;//表示总的最右边界 
	while(scanf("%d",&n)!=EOF)
	{
		rmax = 0;
		memset(tree,-1,sizeof(tree));
		for(i=0;i<n;i++)//输入n个颜色,及其染色范围 
		{
			scanf("%d%d%d",&ls,&rs,&c);
			if(rs>rmax) rmax = rs;//从1开始的下标中存放的值表示前面一单位段的颜色 
			for(j=ls+1;j<=rs;j++)//后来输入的颜色会直接覆盖前面的颜色 
				tree[j] = c;			
		}
		
	//	for(i=1;i<=rmax;i++)
	//		printf("%d ",tree[i]);
	//	printf("\n-----\n");
		
		for(i=0;i<=8001;i++)//初始化,将颜色为i的段数全部赋值为0 
			finalcolor[i] = 0;
			//finalcolor[i].sign = finalcolor[i].num = 0;
			 	
		finalcolor[tree[1]]=1;;
		for(i=2;i<=rmax;i++) 
		{			//如果i的颜色和前一个的不一样的话,段数才能++
			if(tree[i]!=tree[i-1]) 
				finalcolor[tree[i]]++;					
		}//for
		
		for(i=0;i<=8001;i++)
		{
			if(finalcolor[i])
				printf("%d %d\n",i,finalcolor[i]);
		} 
	printf("\n");	
	}//while
	return 0;
}

/*
5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1
3
1 2 3
1 2 2
1 2 1
*/


 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值