HDU--1312 -- Red and Black [简单DFS]

 

Red and Black

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6598    Accepted Submission(s): 4187

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input

  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 Sample Output
  
  
45 59 6 13

 

 

Code:

 

//很简单的深搜, 分配数组不要抠啊, 我老是那么抠抓狂

 

#include"stdio.h"
#include"string.h"
int sign[21][21];
int count=0;
int x,y;

void DFS(int m,int n)
{    
    count++; sign[m][n]=1;
//    printf("m:%d n:%d count:%d\n",m,n,count);
    if(!sign[m][n+1] && n+1<y) DFS(m,n+1);//条件要和自己的情况放在一起
    if(!sign[m+1][n] && m+1<x) DFS(m+1,n);
    if(!sign[m][n-1] && n-1>-1) DFS(m,n-1);
    if(!sign[m-1][n] && m-1>-1) DFS(m-1,n);
}
int main()
{
    int m,n,i,j;
    char str[21];
    while(scanf("%d%d",&y,&x),x&&y)
    {
        count = 0;
        memset(sign,0,sizeof(sign));
        
        for(i=0;i<x;i++)//输入并标识
        {
            scanf("%s",str);
            for(j=0;j<y;j++)
            {
                if(str[j]=='#') sign[i][j] = 1;
                if(str[j]=='@') {m = i; n = j;}
            }
        }        
        DFS(m,n);
//        for(i=0;i<x;i++)
//        {
//            for(j=0;j<y;j++)
//                printf("%d ",sign[i][j]);
//            printf("\n");
//        }        
        printf("%d\n",count); 
            
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值