hdu2594Simpsons’ Hidden Talents(kmp,next)

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2203    Accepted Submission(s): 827


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
  
  
clinton homer riemann marjorie
 

Sample Output
  
  
0 rie 3
 

我的版本

#include <iostream>
#include <cstring>
#include <string>
using namespace std;
const int MAXN = 50005;
int next[MAXN];
string text,pattern;
char tep[MAXN];

void get_next(){
    next[0]=next[1]=0;
    int m = pattern.size();
    for(int i=1; i<m; i++){
        int j=next[i];
        while(j && pattern[i]!=pattern[j]) j=next[j];
        next[i+1]=(pattern[i]==pattern[j]? j+1 : 0);
    }
}

void kmp(){
    int maxLen=0;
    int maxIndex=0;
    int n = text.size();
    int m = pattern.size();
    int j = 0;
    for(int i=0; i<n; i++){
        while(j && text[i]!=pattern[j]) j=next[j];
        if(text[i]==pattern[j]) j++;
        if(j==m && i!=n-1){ //如果s1匹配完毕,但是并没有对齐s2的后缀,则滚回s1首次对齐的位置重新搜索,不过这样效率比较低,遇到极端数据就不好说了
            i=i-j+1;
            maxLen=0;
            j=0;
        }
        maxLen=j;
    }
    if(maxLen>0) cout<<text.substr(n-1-maxLen+1)<<" "<<maxLen<<endl;
    else cout<<0<<endl;
}

int main()
{
    while(cin>>pattern>>text){
        get_next();
        kmp();
    }
    return 0;
}


看了别人的思路,考察的是next数组的认识。

http://blog.csdn.net/chenguolinblog/article/details/8126286

思路:kmp+next数组的应用

分析:
1 题目要求的是给定两个字符串s1 , s2找到s1的最长前缀等于s2的后缀
2 很明显就是next数组的应用,我们知道next[j] = len,表示的前j个字符里面前缀和后缀的最长匹配长度为len。那么我们只要合并两个字符串然后求next数组即可。
3 注意以下的数据
abcabcabcabc
abcabcabcabcabc
输出 12
abcabc
abc
输出 3

我们知道如果合并了s1和s2的话,那么求出来的最长的长度是24 和 6显然是不行的,因为我们忽略了一个地方就是求出的最长的前缀的长度是不能超过
s1和s2的长度的,所以求出最长前缀长度后应该进行讨论。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

#define MAXN 100010

char s1[MAXN/2];
char s2[MAXN/2];
char pattern[MAXN];
int next[MAXN];

void getNext(){
    int n = strlen(s1);
    int m = strlen(s2);
    next[0] = next[1] = 0;
    for(int i = 1 ; i < n+m ; i++){
       int j = next[i];
       while(j && pattern[i] != pattern[j])
           j = next[j];
       next[i+1] = pattern[i] == pattern[j] ? j+1 : 0;
    }
    if(!next[n+m])
      printf("0\n");
    else{
      int tmp = next[m+n];
      s1[tmp] = '\0';
      if(n > m){/*如果第一串大于第二串*/
        if(tmp > m)/*如果tmp>第二串长度直接输出第二串*/
          printf("%s %d\n" , s2 , m);
        else
          printf("%s %d\n" , s1 , tmp);
      }
      else{/*如果第一串小于第二串*/
        if(tmp > n)/*如果tmp>第一串的长度直接输出第一串*/
          printf("%s %d\n" , s1 , n);
        else
          printf("%s %d\n" , s1 , tmp);
      }
    }
}

int main(){
   while(scanf("%s" , s1) != EOF){
       scanf("%s" , s2);
       memcpy(pattern , s1 , sizeof(s1));
       strcat(pattern , s2);
       getNext();
   }
   return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值