hdu4082 Hou Yi's secret 暴力

4 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=4082

Hou Yi's secret

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3006    Accepted Submission(s): 710


Problem Description
Long long ago, in the time of Chinese emperor Yao, ten suns rose into the sky. They burned the crops and scorched the bushes and trees, leaving the people with nothing to eat.

Hou Yi was the greatest archer at that time. Yao wanted him to shoot down nine suns. Hou Yi couldn't do that job with ordinary arrows. So Yao send him to God to get some super powerful magic arrows. Before Hou Yi left, Yao said to him: "In order to manage our country in a better way, I want to know how many years can I live from now on. Please ask God this question for me." Hou Yi promised him.
Hou yi came back from God with ten magic arrows. He shot down nine suns, and the world returned to harmony. When Yao asked Hou Yi about the answer of his question, Hou Yi said: "God told me nothing. But I happened to see a 'life and death book' with your name on it. So I know the answer. But you know, I can't tell you because that's God's secret, and anyone who gives out God's secret will be burned by a thunder!"
Yao was very angry, he shouted: "But you promised me, remember?" Hou Yi said:
"Ooo-er, let's make some compromise. I can't tell you the answer directly, but I can tell you by my only precious magic arrow. I'll shoot the magic arrow several times on the ground, and of course the arrow will leave some holes on the ground. When you connect three holes with three line segments, you may get a triangle. The maximum number of similar triangles you can get means the number of years you can live from now on." (If the angles of one triangle are equal to the angles of another triangle respectively, then the two triangles are said to be similar.)
Yao was not good at math, but he believed that he could find someone to solve this problem. Would you help the great ancient Chinese emperor Yao?
 

Input
There are multiple test cases, and the number of test cases is no more than 12.
The first line of every test case is an integer n meaning that Hou Yi had shot the magic arrow for n times (2 < n <= 18).
Then n lines follow. Each line contains two integers X and Y (-100 < X, Y < 100), the coordinate of a hole made by the magic arrow.
Please note that one hole can be the vertex of multiple triangles.
The input ends with n = 0.
 

Output
For each test case, print a line with an integer indicating the maximum number of similar triangles Yao could get.
 

Sample Input
  
  
3 1 1 6 5 12 10 4 0 0 1 1 2 0 1 -1 0
 

Sample Output
  
  
1 4
 

Source

题意:给最多18个点,问最多有多少个相似的三角形。

分析:18个点。。就枚举所有可以组成的三角形判断相似就好。。注意要判断重点和平行的情况。。

/**
 * @author neko01
 */
//#pragma comment(linker, "/STACK:102400000,102400000")
#include <cstdio>
#include <cstring>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
#define min3(a,b,c) min(a,min(b,c))
#define max3(a,b,c) max(a,max(b,c))
#define pb push_back
#define mp(a,b) make_pair(a,b)
#define clr(a) memset(a,0,sizeof a)
#define clr1(a) memset(a,-1,sizeof a)
#define dbg(a) printf("%d\n",a)
typedef pair<int,int> pp;
const double eps=1e-8;
const double pi=acos(-1.0);
const int INF=0x7fffffff;
const LL inf=(((LL)1)<<61)+5;
bool vis[250][250];
struct point{
    double x,y;
    point(double x=0,double y=0):x(x),y(y) {}
}a[22];
struct triangle{
    double x,y,z;
}b[18*18*18];
bool gao(int i,int j)
{
    if(fabs(b[i].x*b[j].y-b[i].y*b[j].x)<eps&&fabs(b[i].z*b[j].y-b[i].y*b[j].z)<eps)
        return true;
    return false;
}
bool check(int i,int j,int k)
{
    point p1=point(a[i].x-a[j].x,a[i].y-a[j].y);
    point p2=point(a[k].x-a[j].x,a[k].y-a[j].y);
    return fabs(p1.x*p2.y-p1.y*p2.x)<eps;
}
double dis(int i,int j)
{
    return sqrt((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y));
}
int main()
{
    int n,m;
    while(~scanf("%d",&m)&&m)
    {
        clr(vis);
        n=0;
        for(int i=0;i<m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(!vis[x+100][y+100])
            {
                vis[x+100][y+100]=true;
                a[n].x=x;
                a[n++].y=y;
            }
        }
        m=0;
        for(int i=0;i<n-2;i++)
        {
            for(int j=i+1;j<n-1;j++)
            {
                for(int k=j+1;k<n;k++)
                {
                    if(check(i,j,k)) continue;
                    double d1=dis(i,j);
                    double d2=dis(i,k);
                    double d3=dis(j,k);
                    double t[3];
                    t[0]=d1,t[1]=d2,t[2]=d3;
                    sort(t,t+3);
                    if(t[0]+t[1]<=t[2]) continue;
                    b[m].x=t[0],b[m].y=t[1];
                    b[m++].z=t[2];
                }
            }
        }
        int ans=0;
        for(int i=0;i<m;i++)
        {
            int sum=1;
            for(int j=0;j<m;j++)
                if(i!=j&&gao(i,j))
                    sum++;
            if(sum>ans) ans=sum;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值