TOJ 3667 HDU 2830 Matrix Swapping II

Matrix Swapping II

时间限制(普通/Java):1000MS/3000MS     运行内存限制:65536KByte

描述

Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.

输入

There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix

输出

Output one line for each test case, indicating the maximum possible goodness.

样例输入

3 4
1011
1001
0001
3 4
1010
1001
0001


样例输出

4
2

 

自己想不到 是参考别人的

主要是那个排序 排序了 就可以枚举了

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define MAX 1010

char str[MAX];
int dp[MAX];
int a[MAX];

bool cmp(int x,int y)
{
	return x>y;
}

int main()
{
	int n,m,max,i,j;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		max= -1;
		memset(a,0,sizeof(a));
		for(i = 1; i<= n; i++)
		{
			scanf("%s",str+1);
			for(j = 1;j <= m; j++)
			{
				if(str[j] == '1')
				{
					a[j]++;
				}
				else
				{
					a[j] = 0;
				}
				dp[j] = a[j];
			}
			sort(dp+1,dp+m+1,cmp);
			for(j = 1; j <= m; j++)
			{
				max = max > dp[j] * j ? max : dp[j] * j;
			}
		}
		printf("%d\n",max);
	}

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值