LA3942 Trie+DP

Each of the following S lines contains one word from the set. Each word will be at most 100 characters long. There will be no two identical words and all letters in the words will be lowercase.

There is a blank line between consecutive test cases.

You should proceed to the end of file.

Output 

For each test case, output the number, as described above, from the task description modulo 20071027.

Sample Input 

abcd 
4 
a 
b 
cd 
ab

Sample Output 

Case 1: 2


详解大白书 P209


#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MAXN 500000
const int mod=20071027;
struct node
{
    int ch[27];
    int v; // 0表示不是单词,其余数字表示为一个单词。
    node()
    {
        memset(ch,0,sizeof(ch));
        v=0; 
    }
}tree[MAXN];
int tot;
char op[300010];
char word[100];
int d[300010];
void insert(int v)
{
    int len=strlen(word);
    int root=0;
    for(int i=0;i<len;i++)
    {
        if(tree[root].ch[word[i]-'a']==0) tree[root].ch[word[i]-'a']=tot++;
        root=tree[root].ch[word[i]-'a'] ;
    }
    tree[root].v=v;
}
void cheak(int i,int len)
{
    int ans=0;
    int root=0;
    for(int j=i;j<=len;j++)
    {
        if(tree[root].ch[op[j]-'a']==0) break;
        root=tree[root].ch[op[j]-'a'];
        if(tree[root].v) ans+=d[j+1]%mod;
        ans%=mod;
    }
    d[i]=ans;
}
int main()
{
    int kase=1;
    while(~scanf("%s",op))
    {
        memset(tree,0,sizeof(tree));
        int len=strlen(op);
        tot=1;
        int s;
        scanf("%d",&s);
        for(int i=1;i<=s;i++)
        {
            scanf("%s",word);
            insert(i);
        }
        memset(d,0,sizeof(d));
        d[len]=1; // 初始化边界
        for(int i=len-1;i>=0;i--)
        {
            cheak(i,len-1);
        }
        printf("Case %d: %d\n",kase++,d[0]%mod);
    }

}
/**
abcd
4
a
b
cd
ab
abcd
0
**/



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值