欧拉函数

筛选法求欧拉函数

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3452    Accepted Submission(s): 1411


Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 

Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 

Output
Output the result of (a)+ (a+1)+....+ (b)
 

Sample Input
   
   
3 100
 

Sample Output
   
   
3042
 
#include"stdio.h"
#include"string.h"
#include"queue"
#define N 3000000+10
__int64 f[N];
int main()
{
    int a,b,i,j;
    for(i=1;i<N;i++)
        f[i]=i;
    for(i=2;i<N;i+=2)
        f[i]/=2;
    for(i=3;i<N;i+=2)
    {
        if(f[i]==i)
        {
            for(j=i;j<N;j+=i)
            {
                f[j]=f[j]/i*(i-1);
            }
        }
    }
    while(scanf("%d%d",&a,&b)!=-1)
    {
        __int64 s=0;
        for(i=a;i<=b;i++)
            s+=f[i];
        printf("%I64d\n",s);
    }
    return 0;
}


求一个整数的欧拉函数(hdu1787)

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2260    Accepted Submission(s): 910


Problem Description

 

Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem:  
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!
 


 

Input

 

Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
 


 

Output

 

For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.  
 


 

Sample Input

 

  
  
2 4 0
 


 

Sample Output

 

  
  
0 1

 

欧拉函数:在数论,对正整数n,欧拉函数是小于或等于n的数中与n互质的数的数目。
n是质数p的k次幂,
f(n)=p^k-p^(k-1)=(p-1)*p^(k-1);     (质因子减一乘以质因子的k-1次方)

 
或者: f(x)=x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…..(1-1/pn),
其中p1, p2……pn为x的所有质因数,x是不为0的整数。
f(1)=1(唯一和1互质的数(小于等于1)就是1本身)。
(注意:每种质因数只一个。比如12=2*2*3
 欧拉公式 那么f(12)=12*(1-1/2)*(1-1/3)=4;)
 
化简得:f(x)=x/(p1*p2*...*pn)*(p1-1)*(p2-1)*...*(pn-1);
解题思路:从1到n-1求出所有和n互质的数,然后用N减去这些数的个数就行了。求与N互质的数可以用欧拉函数;

 

#include<stdio.h>
int phi(int n)
{
 int s=1,i;
 for(i=2;i*i<=n;i++)           //只能从2开始
 {
  if(n%i==0)              //质因子减一
  {
   n/=i;
   s*=i-1;            //即s=s*(i-1);
  }
  while(n%i==0)          //质因子的k-1次方
  {
   n/=i;
   s*=i;
  }
 }
 if(n>1)                //最后一个质因子
  s*=n-1;
 return s;
}
int main()
{
 int n;
 while(scanf("%d",&n),n)
  printf("%d\n",n-phi(n)-1);           //去掉1这个因子
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值