【PAT】【Advanced Level】1010. Radix (25)

1010. Radix (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible
原题链接:

https://www.patest.cn/contests/pat-a-practise/1010

https://www.nowcoder.com/questionTerminal/439e424da87b4fb48c9992f356718353

思路:

首先用线性搜索。。从小到大,36为止

发现最大不是36。

然后层层优化,最终能够过 24/25 个测试点,剩下一个超时

网上找题解

用二分查找,同时对相等的情况、不唯一的情况特殊处理

相等直接输出

只有b为个位数时才会不唯一

code:

24分:

#include<iostream>
#include<cstring>
#include<string>
#include<map>
using namespace std;

map<char,int> cti;
char itc[36]={'0','1','2','3','4','5','6','7','8','9','a','b','c','d','e','f','g','h','i','j','k','l','m','n','o','p','q','r','s','t','u','v','w','x','y','z'};

long long  cha(string a,string b,int ra)
{
    long long te=0;
    for (int i=0;i<a.length();i++)
    {
        te*=ra;
        te+=cti[a[i]];
    }
    //cout<<te<<endl;
    if(b.length()==1)
    {
        return te+1;
    }
    int num=0;
    for (long long i=1;i<=te;i++)
    {
        long long te1=0;
        int fl=0;
        for (int j=0;j<b.length();j++)
        {
            if (cti[b[j]]>=i)
            {
                fl=1;
                break;
            }
            te1*=i;
            te1+=cti[b[j]];
            if (te1>te)
            {
                fl=1;
                break;
            }
        }
        if (fl==1) continue;
        //cout<<te1<<endl;
        if (te1==te)
        {
            return i;
        }
    }
    return -1;
}


int main()
{
    for (int i=0;i<=9;i++)   cti['0'+i]=i;
    for (int i=0;i<26;i++)  cti['a'+i]=i+10;
    string a,b;
    int tag,ra;
    cin>>a>>b>>tag>>ra;
    string ori,des;
    if (tag==1)
    {
        ori=a;
        des=b;
    }
    else
    {
        ori=b;
        des=a;
    }
    int re=cha(ori,des,ra);
    if (re==-1)
        cout<<"Impossible";
    else
        cout<<re;
    return 0;
}

AC:

#include<iostream>
#include<cstring>
#include<string>
#include<map>
using namespace std;

map<char,int> cti;
char itc[36]={'0','1','2','3','4','5','6','7','8','9','a','b','c','d','e','f','g','h','i','j','k','l','m','n','o','p','q','r','s','t','u','v','w','x','y','z'};

long long cha(string a,string b,int ra)
{
    if (a==b) return ra;
    long long te=0;
    int ma=0;
    for (int i=0;i<a.length();i++)
    {
        te*=ra;
        te+=cti[a[i]];
    }
    if(b.length()==1)
    {
        return te+1;
    }
    long long r=te+1;
    long long  l=1;
    long long  i=(l+r)/2;
    while (r-l>1)
    {
        long long te1=0;
        int fl=0;
        for (int j=0;j<b.length();j++)
        {
            if (cti[b[j]]>i)
            {
                fl=1;
                break;
            }
            te1*=i;
            te1+=cti[b[j]];
            if (te1>te)
            {
                fl=2;
                break;
            }
        }
        if (fl==1)
        {
            l=i;
            i=(l+r)/2;
            continue;
        }
        else if (fl==2)
        {
            r=i;
            i=(l+r)/2;
            continue;
        }
        if (te1==te)
        {
            return i;
        }
        else
        {
            l=i;
            i=(l+r)/2;
        }
    }
    return -1;
}


int main()
{
    for (int i=0;i<=9;i++)   cti['0'+i]=i;
    for (int i=0;i<26;i++)  cti['a'+i]=i+10;
    string a,b;
    int tag,ra;
    cin>>a>>b>>tag>>ra;
    string ori,des;
    if (tag==1)
    {
        ori=a;
        des=b;
    }
    else
    {
        ori=b;
        des=a;
    }
    long long re=cha(ori,des,ra);
    if (re==-1)
        cout<<"Impossible";
    else
        cout<<re;
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值