【PAT】【Advanced Level】1040. Longest Symmetric String (25)

1040. Longest Symmetric String (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11
原题链接:

https://www.patest.cn/contests/pat-a-practise/1040

思路:

循环一遍分别判断单数、双数的情况即可

CODE:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
using namespace std;

int main()
{
    string str;
    getline(cin,str);
    int ma=1;
    for (int i=0;i<str.length()-1;i++)
    {
        if (str[i]==str[i+1])
        {
            int t=0;
            while (i-t>=0&&i+t+1<str.length())
            {
                if (str[i-t]!=str[i+1+t]) break;
                t++;
            }
            ma=max(2*t,ma);
        }
        int tt=0;
        while (i-1-tt>=0 && i+tt+1<str.length())
        {
            if (str[i-1-tt]!=str[i+1+tt]) break;
            tt++;
        }
        ma=max(ma,1+tt*2);
    }
    cout<<ma<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值