【PAT】【Advanced Level】1105. Spiral Matrix (25)

11 篇文章 0 订阅

1105. Spiral Matrix (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrixis filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and ncolumns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
原题链接:

https://www.patest.cn/contests/pat-a-practise/1105

思路:

先求m,n

再根据要求模拟

注意边界情况

CODE:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<vector>
#include<algorithm>
#define N 10010
using namespace std;
vector<int> t;
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	
	int nn;
	scanf("%d",&nn);
	int m,n;
	for(int i=1;i*i<=nn;i++)
	{
		if (nn%i==0)
		{
			n=i;
			m=nn/i;
		}
	}
	//cout<<m<<" "<<n<<endl;
	int res[m][n];
	for (int i=0;i<nn;i++)
	{
		int num;
		scanf("%d",&num);
		t.push_back(num);
	}
	sort(t.begin(),t.end(),cmp);
	int tb[2]={0,m-1},lr[2]={0,n-1};
	int x=0,y=0,r=0;
	int nx[2]={0,1};
	while(r<nn)
	{
		
		res[x][y]=t[r];
		//cout<<x<<" "<<y<<" "<<res[x][y]<<" "<<nx[0]<<" "<<nx[1]<<endl;
		r++;
		x+=nx[0];
		y+=nx[1];
		if (y>lr[1])
		{
			y--;
			x++;
			tb[0]++;
			nx[0]=1;
			nx[1]=0;
		}
		else
		if (x>tb[1])
		{
			x--;
			y--;
			lr[1]--;
			nx[0]=0;
			nx[1]=-1;
		}
		else
		if (y<lr[0])
		{
			y++;
			x--;
			tb[1]--;
			nx[0]=-1;
			nx[1]=0;
		}
		else
		if (x<tb[0])
		{
			x++;
			y++;
			lr[0]++;
			nx[0]=0;
			nx[1]=1;
		}
	}
	for (int i=0;i<m;i++)
	{
		for (int j=0;j<n;j++)
		{
			if (j!=0) printf(" ");
			printf("%d",res[i][j]);
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值