【PAT】【Advanced Level】1112. Stucked Keyboard (20)

1112. Stucked Keyboard (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string "thiiis iiisss a teeeeeest" we know that the keys "i" and "e" might be stucked, but "s" is not even though it appears repeatedly sometimes. The original string could be "this isss a teest".

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k ( 1<k<=100 ) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and "_". It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:
3
caseee1__thiiis_iiisss_a_teeeeeest
Sample Output:
ei
case1__this_isss_a_teest
原题链接:

https://www.patest.cn/contests/pat-a-practise/1112

思路:

扫描原字符串

如果与前一位相同,累加重复个数,如果达到阈值N,且没有淘汰标记,则次数清零,加入备选数组。

如果与前一位不同,若前一位不是0(恰好累加到阈值N),则说明前一位的字符不符合要求,直接打淘汰标记。

最后将备选数组中的元素再筛选一遍即可

输出时,用while,遇到坏的,加阈值N,遇到好的,加1。

CODE:

#include<iostream>
#include<cstring>
#include<string>
#include<map>
#include<vector>
using namespace std;
map<char,int> ma;
map<char,int> ma1;
vector<char> vec;
int main()
{
	int n;
	cin>>n;
	string t;
	cin>>t;
	for (int i=0;i<t.length();i++)
	{
		if (i==0)
		{
			ma[t[i]]=1;
		}
		else if (t[i]!=t[i-1])
		{
			ma[t[i]]=1;
			if (ma[t[i-1]]!=0) ma1[t[i-1]]=-1;
			ma[t[i-1]]=0;
		}
		else
		{
			ma[t[i]]++;
			if (ma[t[i]]==n)
			{
				//cout<<t[i]<<endl;
				if(ma1[t[i]]!=-1)
				{
					if (ma1[t[i]]!=1)
						vec.push_back(t[i]);
					ma1[t[i]]=1;
				}
				ma[t[i]]=0;
			}
		}
	}
	for (int i=0;i<vec.size();i++)
	{
		if (ma1[vec[i]]!=-1)
		{ 
			cout<<vec[i];
		}
	}
	cout<<endl;
	int j=0;
	while (j<t.length())
	{
		cout<<t[j];
		if (ma1[t[j]]==-1) 
			j++;
		else
			j+=n;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
项目:使用 JavaScript 编写的杀死幽灵游戏(附源代码) 杀死鬼魂游戏是使用 Vanilla JavaScript、CSS 和 HTML 画布开发的简单项目。这款游戏很有趣。玩家必须触摸/杀死游荡的鬼魂才能得分。您必须将鼠标悬停在鬼魂上 - 尽量得分。鬼魂在眨眼间不断从一个地方移动到另一个地方。您必须在 1 分钟内尽可能多地杀死鬼魂。 游戏制作 这个游戏项目只是用 HTML 画布、CSS 和 JavaScript 编写的。说到这个游戏的特点,用户必须触摸/杀死游荡的幽灵才能得分。游戏会根据你杀死的幽灵数量来记录你的总分。你必须将鼠标悬停在幽灵上——尽量得分。你必须在 1 分钟内尽可能多地杀死幽灵。游戏还会显示最高排名分数,如果你成功击败它,该分数会在游戏结束屏幕上更新。 该游戏包含大量的 javascript 以确保游戏正常运行。 如何运行该项目? 要运行此游戏,您不需要任何类型的本地服务器,但需要浏览器。我们建议您使用现代浏览器,如 Google Chrome 和 Mozilla Firefox。要玩游戏,首先,单击 index.html 文件在浏览器中打开游戏。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值