1001 Post Robot--字符串的比较问题

Post Robot

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
DT is a big fan of digital products. He writes posts about technological products almost everyday in his blog. But there is such few comments of his posts that he feels depressed all the day. As his best friend and an excellent programmer, DT asked you to help make his blog look more popular. He is so warm that you have no idea how to refuse. But you are unwilling to read all of his boring posts word by word. So you decided to write a script to comment below his posts automatically. After observation, you found words “Apple” appear everywhere in his posts. After your counting, you concluded that “Apple”, “iPhone”, “iPod”, “iPad” are the most high-frequency words in his blog. Once one of these words were read by your smart script, it will make a comment “MAI MAI MAI!”, and go on reading the post. In order to make it more funny, you, as a fan of Sony, also want to make some comments about Sony. So you want to add a new rule to the script: make a comment “SONY DAFA IS GOOD!” when “Sony” appears.
 

Input
  
  
A blog article described above, which contains only printable characters(whose ASCII code is between 32 and 127), CR(ASCII code 13, ‘\r’ in C/C++), LF(ASCII code 10, ‘\n’ in C/C++), please process input until EOF. Note all characters are case sensitive. The size of the article does not exceed 8KB.
 

Output
  
  
Output should contains comments generated by your script, one per line.
 

Sample Input
  
  
Apple bananaiPad lemon ApplepiSony 233 Tim cook is doubi from Apple iPhoneipad iPhone30 is so biiiiiiig Microsoft makes good App.
 

Sample Output
  
  
MAI MAI MAI! MAI MAI MAI! MAI MAI MAI! SONY DAFA IS GOOD! MAI MAI MAI! MAI MAI MAI! MAI MAI MAI! 注意的问题:1.gets(s) while(gets(s)!=NULL) 2.if else if的应用;3.字符的命令是双等号,不是一个等号,一个等号是赋值的意思 4.定义64位的字符串,__int 64 a[100005],scanf("%I64d",&a[i])
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char s[9000];
int main()
{

	while(gets(s)!=NULL)
	{
		int n=strlen(s);
		for(int i=0;i<n;i++)
		{
			if((s[i]=='A')&&(s[i+1]=='p')&&(s[i+2]=='p')
				&&(s[i+3]=='l')&&(s[i+4]='e'))
				printf("MAI MAI MAI!\n");

			else if((s[i]=='i')&&(s[i+1]=='P')
					&&(s[i+2]=='h')&&(s[i+3]=='o')&&(s[i+4]=='n')&&(s[i+5]=='e'))
				 printf("MAI MAI MAI!\n");

			else if((s[i]=='i')&&(s[i+1]=='P')
					&&(s[i+2]=='o')&&(s[i+3]=='d'))
				      printf("MAI MAI MAI!\n");

			else if((s[i]=='i')&&(s[i+1]=='P')&
					&(s[i+2]=='a')&&(s[i+3]=='d'))
					printf("MAI MAI MAI!\n");

			else if((s[i]=='S')&&(s[i+1]=='o')
					&&(s[i+2]=='n')&&(s[i+3]=='y'))
			   printf("SONY DAFA IS GOOD!\n");

		}
	}
		return 0;

}









评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值