hdu 1005 矩阵快速幂

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 102931    Accepted Submission(s): 24906


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

#define M 7
struct Matrix{
    int a[2][2];
    Matrix(){memset(a,0,sizeof a);}
};
Matrix mul(Matrix x,Matrix y)
{
    Matrix ans;
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            for(int k=0;k<2;k++)
            {
                ans.a[i][j] = (ans.a[i][j] + x.a[i][k]*y.a[k][j])%M;
            }
        }
    }
    return ans;
}
int quick_mi(Matrix t,int n)
{
    Matrix res;
    res.a[0][0]=1,res.a[0][1]=0;
    res.a[1][0]=0,res.a[1][1]=1;
    while(n>0)
    {
        if(n&1) res = mul(res,t);
        t = mul(t,t);
        n>>=1;
    }
    return (res.a[0][0]+res.a[0][1])%M;
}

int main()
{
    int A,B,N;
    Matrix mat;
    while(cin >> A >> B >> N)
    {
        if(A+B+N==0) break;
        mat.a[0][0] = A,mat.a[0][1] = B;
        mat.a[1][0] = 1,mat.a[1][1] = 0;
        cout << quick_mi(mat,N-2) << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值