Cookie Selection - CF_GYM, 100112C 中位数动态查找

题目链接 CF_GYM, 100112C

As chief programmer at a cookie production plant you have many responsibilities, one of them being that the cookies produced and packaged at the plant adhere to the very demanding quality standards of the Nordic Cookie Packaging Consortium(NCPC).

At any given time, your production line is producing new cookies which are stored in a holding area, awaiting packaging.From time to time there are also requests from the packaging unit to send a cookie from the holding area to be packaged. Naturally,you have programmed the system so that there are never any packaging requests sent if the holding area is empty. What complicates the matter is the fact that representatives of the NCPC might make a surprise inspection to check that your cookies are up to standard.Such an inspection consists of the NCPC representatives demanding that the next few cookies sent to the packaging unit instead be handed over to them; if they are convinced that these cookies look(and taste) the same, you pass the inspection, otherwise you fail

Fortunately, the production plant has invested in a new measurement thingamajig capable of measuring cookie diameters with a precision of 1 nanometre (nm). Since you do not have the time to always be on the look out for cookie craving NCPC inspectors, you have decided that a sensible strategy to cope with the inspections is toal ways send a cookie having the median diameter among all cookies currently in the holding area to the packaging unit on a request. If there is no cookie exhibiting the median diameter in the holding area, you instead send the smallest cookie larger than the median to the packaging unit, hoping it will please the NCPC inspectors. This means that, if the cookies were sorted in order of ascending diameter, and if there was an odd number c of cookies in the holding area, you would send the cookie at position (c + 1)/2 in the sorted sequence, while if there was an even number c of cookies in the holding area, you would send the cookie at position (c/2) + 1 in the sorted sequence to the packaging unit on a request.

Input

Each line of the input contains either a positive integer d, indicating that a freshly baked cookie with diameter dnm has arrived at the holding area, or the symbol ’#’, indicating a request from the packaging unit to send a cookie for packaging. There are at most 600 000 lines of input, and you may assume that the holding area is empty when the first cookie in the input arrives to the holding area. Furthermore, you have read somewhere that the cookie oven at the plant cannot produce cookies that have a diameter larger than 30 centimetres (cm) (or 300 000 000nm).

Output

A sequence of lines, each indicating the diameter in nm of a cookie sent for packaging, in the same order as they are sent.

Sample Input 1

1

2

3

4

#

#

#

#

Sample Output 1

3

2

4

1

Sample Input 2

1

#

2

#

3

#

4

#

Sample Output 2

1

2

3

4

题目意思:动态的插入一些数,每次输入‘#’时,从数组中取出中位数拿走。

解题思路:用两个优先队列,第一个保存中位数之前所有的数(顺序),第二个保存中位数及之后所有的数(逆序),每次取出第二个队列中第一个元素就是结果。但注意,每次插入数据时要插入到哪个队列中,弹出数据后也要调整两个队列。

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;

#define maxn 300000
#define inf 0x3fffffff
int cnt = 0;
char s[20];
priority_queue<int> que1;
priority_queue<int> que2;

void balance(){
    int len1 = que1.size(), len2 = que2.size();
        if(len1>len2){
            int temp = que1.top();
            que1.pop();
            que2.push(-temp);
    }
    if(que1.size()>0 && que2.size()>0){
        int t1 = que1.top(), t2 = que2.top()*(-1);
       // cout << "##" <<t1 <<" " <<t2<<endl;
        if(t1 > t2){
            que1.pop();
            que2.pop();
            que2.push(-t1);
            que1.push(t2);
        }
    }
}

int main(){
    while(gets(s)){
        if(s[0]=='#'){
            printf("%d\n",-que2.top());
            que2.pop();
            balance();
        }else{
            que1.push(atoi(s));
            balance();
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值