Pie - POJ 3122 二分

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655
题目意思:有F个朋友加上自己,分n个蛋糕,要求每个人所得面积都相同(其实体积相同,因为高度都相同,所以求面积即可),每个人只能从一个蛋糕中取,不能从一个蛋糕取一部分从另个蛋糕取一部分,一个蛋糕可以分给多个人。

解题思路:二分蛋糕面积,对于每个值,检查每个人是否能分到。注意对于浮点数二分,还是用循环多次比较精确。整数就用while循环。

代码:

#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;

#define maxn 10000+10
#define A 100000
#define INF 999999999
//
int N,F;
int r[maxn];
int maxr;
/
bool ok(double m){
    if(m==0) return true;
    int cnt = 0;
    for(int i=0;i<N;i++){
        cnt += (int)(r[i]/m);
    }
    return cnt >= F+1;
}
void solve(){
    double l=0, r = maxr,mid;
    for(int i=0;i<100;i++){
        mid = (l+r)/2;
        if(ok(mid)) l = mid;
        else r = mid;
    }
    printf("%.4f\n",r*acos(-1));
}

int main(){
    int T;
    cin >> T;
    while(T--){
        scanf("%d %d",&N,&F);
        maxr = 0;
        for(int i=0;i<N;i++){
            scanf("%d",&r[i]);
            r[i] = r[i]*r[i];
            if(r[i]>maxr) maxr = r[i];
        }
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值