poj 2492 A Bug's Life 带权并查集

A Bug's Life
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 30837 Accepted: 10090

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
题意:有个喜欢yy的砖家最近对某种昆虫感兴趣了,于是基于他个人爱好做了个假设 -- 这种昆虫之和异性交配。基于此,他给它的昆虫都标上了号,观察他们xxoo,并做好记录,他爽完了之后就不管了,将剩余的工作交给了你,人在江湖,身不由己啊。。只能苦逼的替他完成剩下的工作,不过没关系!只要是ACM你都不觉得累!:)。。现在让你判断记录中是否有可疑同性交配的情况。

思路:带权并查集。

代码:

#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 2000+10

int n,k;
int fa[maxn],re[maxn];   // 0:相对根节点同性  1:异性

void init(){
	for(int i=1;i<=n;i++){
		fa[i] = i;
		re[i] = 0;
	}
}

int findRoot(int t){
	int temp = fa[t];
	if(temp==t) return t;
	fa[t] = findRoot(temp);
	re[t] = (re[t]+re[temp])%2;
	return fa[t];
}

void unionSet(int a,int b){
	int x = findRoot(a);
	int y = findRoot(b);
	if(x==y) return;
	fa[x] = y;
	
	// update relation 
	if(re[a]==1) re[x] = re[b];
	else re[x] = (re[b]+1)%2;
}

int main(){
	int T;
	scanf("%d",&T);
	for(int t=1;t<=T;t++){
		scanf("%d %d",&n,&k);
		int a,b;
		init();
		bool flag = false;
		while(k--){
			scanf("%d %d",&a,&b);
			if(findRoot(a) == findRoot(b)){
				if(re[a] == re[b]) flag = true;
			}else{
				unionSet(a,b);
			}
		}
		printf("Scenario #%d:\n",t);
		if(flag){
			printf("Suspicious bugs found!\n\n");
		}else{
			printf("No suspicious bugs found!\n\n");
		}
	}
	return 0;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值