hdu 1050 Moving Tables(贪心算法---区间覆盖,重叠数)

问题描述:

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

输入:

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

输出:

The output should contain the minimum time in minutes to complete the moving, one per line.



样例输入:

3

10 20 

30 40 

50 60 

70 80 

1 3 

2 200 

10 100 

20 80 

30 50

样例输出:

10

20

30


问题分析:

主要是注意两点

1、房子的号是对称的,即1-3 2-4是同一个,正确的结果是用两个10mins ,所以代码里采用了二分法,这样可以有效的将重叠这部分表示在一起 即重叠量为2

2、注意移动的房间之间 没有规定是由小到大,或者由大到小,所以有一步是比较大小 交换

代码:

#include<iostream>
using namespace std;
void swap(int &a,int &b)
{
int temp;
temp=a;
a=b;
b=temp;
}//交换函数
struct point
{
int s;
int e;
}a[200];
int main()
{
int n,m,i,j,t;

while(cin>>m)
{

for(i=0;i<m;i++)
{
int b[200]={0};//注意这里一定要重新初始化为0;
            cin>>n;
for(j=0;j<n;j++)
{
cin>>a[j].s>>a[j].e;
if(a[j].s>a[j].e) swap(a[j].s,a[j].e);//交换函数 是为了保证由房间号小的向大的移动,主要是为了后面的比较

   a[j].s=(a[j].s+1)/2;//这里用了二分查找 注意主要是因为房间号是对称的 比如 1-3 2-4 是会重合的,自己可以找几个例子
   a[j].e=(a[j].e+1)/2;//验证一下,这样可以使3 4表示成同一个房间
   for(t=a[j].s;t<=a[j].e;t++)
   {
  b[t]++;//前面已交换之后则s<e,出现过得房间进行赋值,出现的越多,则值越大
   }
}
int max=0;
for(j=1;j<200;j++)
{
if(b[j]>max)
max=b[j];//最终值大的说明重叠数是最多的,则说明需要的时间这个多个10mins
}
cout<<max*10<<endl;
}
}


return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值