CocoaPods 版本升级2016最新版

升级 OS X El Capitan 后,Time Machine 恢复下,随后因为遇到 octopress 无法更新博客问题,一番折腾 octopress 适配了 OS X El Capitan,然而事情总没有那么简单,又丢过来一个问题。


和往常一样使用 Cocoapods ,执行命令:

$ pod install





#输出信息

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/dependency.rb:296:in `to_specs': Could not find 'cocoapods' (>= 0) among 59 total gem(s) (Gem::LoadError)
    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/dependency.rb:307:in `to_spec'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:47:in `gem'
    from /usr/local/bin/pod:22:in `<main>'



查看 Ruby 版本:

$ ruby -v

看来是升级 Ruby 2.2.3 导致的问题,更新下 Cocoapods 即可,更新步骤:


1、 更新 gem ,国内需切换 gem source

$ sudo gem update --system


切换 gem source
$ gem sources --add https://ruby.taobao.org/ --remove https://rubygems.org/



$ gem sources -l
*** CURRENT SOURCES***


https://ruby.taobao.org

2、 安装 cocoapods

$sudo gem install cocoapods


和安装过程是一样的,再次查看 pod 版本:

$ pod --version



1.0.1


搞定~


----结合下面错误处理----

1.移除现有Ruby默认源

$gem sources --remove https://rubygems.org/


2.使用新的源
$gem sources -a https://ruby.taobao.org/


3.验证新源是否替换成功

$gem sources -l


4.安装CocoaPods
(1) $sudo gem install cocoapods 备注:苹果系统升级 OS X EL Capitan 后改为$sudo gem install -n /usr/local/bin cocoapods
(2) $pod setup


5.更新gem

$sudo gem update --system


6. 新建工程,并在终端用cd指令到文件夹内

$pod search 第三方


7.新建文件 vim “Podfile”,

$vim Podfile
写入以下内容并保存 小提示:(终端vim文件 按 i 可编辑 ,esc 退出编辑,:wq  可保存退出)
platform:ios, '6.0'   
pod 'AFNetworking', '~> 2.3.1'    <-------第三方


8.导入第三方库

$pod install


9.退出终端


以下是我用以前的安装流程安装时出现的一些错误

终端  cocoapods 下载bug调试:


错误1:

Error fetching http://ruby.taobao.org/:
bad response Not Found 404 (http://ruby.taobao.org/specs.4.8.gz)


解决方案:把安装流程中 $gem sources -a http://ruby.taobao.org/   ---改为---->$gem sources -a https://ruby.taobao.org/


错误2:

ERROR:  While executing gem ... (Errno::EPERM)
Operation not permitted - /usr/bin/pod


解决方案:苹果系统升级OS X EL Capitan后会出现的插件错误,将安装流程 4.安装CocoaPods 的 (1)sudo gem install cocoapods ——>改为sudo gem install -n /usr/local/bin cocoapods


错误3:

[!] Unable to satisfy the following requirements: - `AVOSCloud (~> 3.1.6.3)` required by `Podfile`
Specs satisfying the `AVOSCloud (~> 3.1.6.3)` dependency were found, but they required a higher minimum deployment target.


解决方案:安装流程:Podfile文件 中   platform:ios, ‘6.0’  后边的 6.0 是平台版本号 ,一定要加上

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u012265444/article/details/52100119
文章标签: CocoaPods 升级
个人分类: 经验
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭