HDU-1394 Minimum Inversion Number

18 篇文章 0 订阅
4 篇文章 0 订阅

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

————————————————————紧张的分割线————————————————————

思路:该题的难度比起基础题已经有了提高。首先考虑如何找到逆序数对。最自然的思路就是枚举给出数列的数字,它后面会有谁比它小,则构成一对逆序数字,但是枚举的同时需要记忆已经枚举了哪些数字,之后不能再使用这些数字。记忆和判断都是消耗很大的。此时应该使用线段树,每输入数列的一个数字,完成一次统计。但是问题在于,每输入一个数字,并不知道后面分别是谁。但是前面的数字是知道的!对,逆向思维。对每一个数字,看在输入它之前都有谁比它大即可。而对大小的判断也可以省略。那就是给出的数列恰好是0~n-1。那就按照这个位置分别存入线段树即可。每输入一个子叶,看它右边的区间内(比它大的数),有几个(注意)已经输入了,那就构成一个逆序数对。

最后是找到最小个数的逆序数对,这就是归纳的过程了。对于给定数列(0~n-1),每个数字k都有k个比它小的数和n-k-1个比它大的数。得到公式ans = ans + (n-x[i]-1) - x[i];

代码如下:

#include <cstdio>
#include <algorithm>
using namespace std;

#define lson l, m, id << 1
#define rson m+1, r, id << 1|1
const int N = 5010;
int tree[N << 2];
void Sum(int id) {
    tree[id] = tree[id<<1] + tree[id<<1|1];//该线段树储存的是“个数”
}
void build(int l, int r, int id) {
    tree[id] = 0;//建树的时候初始化为0
    if(l == r)  return;
    int m = (l+r) >> 1;
    build(lson);    build(rson);
}
void update(int pos, int l, int r, int id) {
    if(l == r) {
        tree[id]++;
        return ;
    }
    int m = (l+r) >> 1;
    if(pos <= m)update(pos, lson);
    else        update(pos, rson);
    Sum(id);
}//单点更新,读到该点,该点变为1,向上更新整棵线段树的时候“已读点个数”要增加
int query(int L, int R, int l, int r, int id) {
    if(L <= l&&r <= R)  return tree[id];
    int m = (l+r) >> 1;
    int ret = 0;
    if(L <= m)  ret += query(L, R, lson);
    if(R > m)   ret += query(L, R, rson);
    return ret;
}//更新之前,进行询问,看看有几个比该点要大的点已读入,统计一下
int x[N];
int main() {
	int n;
	while(~scanf("%d", &n)) {
        build(0, n-1, 1);
        int ans = 0;
        for(int i = 0; i < n; i++) {
            scanf("%d", x+i);
            ans += query(x[i], n-1, 0, n-1, 1);
            update(x[i], 0, n-1, 1);
        }
        int res = ans;//递推出最优解
        for(int i = 0; i < n; i++) {
            ans += (n-x[i]-1) - x[i];
            res = min(res, ans);
        }
        printf("%d\n", res);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值