POJ-1308 Is It A Tree?

Is It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
   

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source

North Central North America 1997

————————————————————顺秒的分割线————————————————————

思路:开始刷并查集。这道题也是比较基础的并查集。需要做的就只有两件事,一件事是建立并查集,另一件事是判断数据结构的正确性。

根据题意,输入一些点对,将第一个点作为第二个点的父亲,建立并查集,如果一个结点拥有两个父亲或者该并查集有两个祖先,则输出不是树。否则输出是树。

进行逻辑上的判断:

1. 若将x作为y的父亲之前,y已经有了别的父亲,说明不是树。

2. 若x和y已经属于相同集合,连接起来就会成环。

3. 若连接结束之后不是一棵树而是森林(注意!!!),则不是树。

前两个条件用Find()找到祖先即可判断,那么怎么判断是树而不是森林呢?

——森林有多个祖先,而树只有一个祖先。祖先,就是说没有父亲。在建立的过程中,就不会出现在儿子的位置。

方法就是——若在父亲位置上出现过的数字,没有在儿子的位置出现,那么它是祖先。

只需两个bool数组。

代码如下:

/****************************************/
 #include <cstdio>
 #include <cstdlib>
 #include <cstring>
 #include <algorithm>
 #include <cmath>
 #include <stack>
 #include <queue>
 #include <vector>
 #include <map>
 #include <string>
 #include <iostream>
 using namespace std;
/****************************************/
const int N = 105;
int ok, fa[N];
bool vis[N], mat[N];

int Find(int x)
{
	if(x != fa[x])
		fa[x] = Find(fa[x]);
	return fa[x];
}

void Union(int x, int y)
{
	int fx = Find(x), fy = Find(y);
	if(fy != y || fx == fy) {//成环
		ok = 0;
		return ;
	}
	if(fx != fy) {
		fa[fy] = fx;
	}
}

int main()
{
	int x, y, cas = 1;
	while(scanf("%d%d", &x, &y)) {
		if(x == -1 && y == -1)
			break ;
		ok = 1;
		int zu = 0;
		for(int i = 0; i < N; i++)
			fa[i] = i;
		memset(vis, 0, sizeof(vis));
		memset(mat, 0, sizeof(mat));
		while(x||y) {
			mat[x] = true;
			vis[y] = true;
			Union(x, y);
			scanf("%d%d", &x, &y);
		}
		if(ok) {
			for(int i = 1; i < N; i++) {
				if(mat[i]) {//若曾经出现在父亲的位置
					if(!vis[i])
						zu++;
					if(zu > 1) {
						ok = 0;
						break;
					}
				}
			}
		}
		printf("Case %d is %sa tree.\n", cas++, ok ? "" : "not ");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值