POJ-2492 A Bug's Life

A Bug's Life
Time Limit: 10000MS Memory Limit: 65536K
   

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany

————————————————————水水的分割线————————————————————

思路:水体也贴!这是关系性并查集的水题。之前做过最经典的食物链。要想学关系性并查集,还是先学这个,学会了就可以秒很多题了。思路可以看上面的博客。

此外值得一说,这道题根本就没说每组输出后加一个空行,尼玛我就不吐槽了。

代码如下:

/*
ID: j.sure.1
PROG: 
LANG: C++
*/
/****************************************/
 #include <cstdio>
 #include <cstdlib>
 #include <cstring>
 #include <algorithm>
 #include <cmath>
 #include <stack>
 #include <queue>
 #include <vector>
 #include <map>
 #include <string>
 #include <iostream>
 using namespace std;
/****************************************/
const int N = 2005;
const int r_sex[2][2] = {1, 0, 0, 1}, r_gra[2][2] = {0, 1, 1, 0};
int pa[N], relat[N];
int ok;
//0表示同性 1表示异性
int Find(int x)
{
	int tmp;
	if(x != pa[x]) {
		tmp = pa[x];
		pa[x] = Find(tmp);
		relat[x] = r_gra[relat[x]][relat[tmp]];//根据和父亲的关系、父亲和爷爷的关系,压缩一个父亲,更新关系域
	}
	return pa[x];
}

void Union(int x, int y)
{
	int fx = Find(x), fy = Find(y);
	if(fx != fy) {
		pa[fy] = fx;
		relat[fy] = r_sex[relat[x]][relat[y]];//根据A和祖先的关系、B和祖先的关系、A和B异性、推出B和A的祖先关系,并以A的祖先作为B的新祖先
		return ;
	}
	if((relat[x] + 1) % 2 != relat[y])//如果A、B在同一个集合,直接逻辑判断
		ok = 0;
}

int main()
{
	int cas;
	scanf("%d", &cas);
	for(int t = 1; t <= cas; t++) {
		int n, m, x, y;
		ok = 1;
		scanf("%d%d", &n, &m);
		for(int i = 0; i <= n; i++) {
			pa[i] = i;
			relat[i] = 0;
		}
		for(int i = 0; i < m; i++) {
			scanf("%d%d", &x, &y);
			Union(x, y);
		}
		printf("Scenario #%d:\n", t);
		if(ok)
			printf("No suspicious bugs found!\n\n");
		else
			printf("Suspicious bugs found!\n\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值