HDU-1085 Holding Bin-Laden Captive!

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)



Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
  
  
1 1 3 0 0 0
 

Sample Output
  
  
4
 
————————————————————集训17.1的分割线————————————————————
前言:第一次做母函数的题目。根据我的个人理解,母函数是一种求组合数的数学方法。因为多项式是个神奇的东西。把物品当做变量x之后,用系数来表示方案数、指数表示物品累加值、求多项式拆开过程来表示多种物品的组合数,通过最终得到的系数来确定解。
模板会另外贴出来。
思路:本题有三个物品,权重分别是1 2 5,根据数据范围所有的钱加起来接近10000,是最大价值,每样物品都可以从不取到全取。套模板。最后遍历0~P+1,有哪个价值的系数是0说明拼不出来哪个价值。
代码如下:
/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <climits>
#include <iostream>
#define INF 0x3f3f3f3f
using namespace std;
/****************************************/
const int maxP = 1e4;
int num[3], c1[maxP], c2[maxP];
int v[]={1, 2, 5};

int main()
{	
#ifdef J_Sure
//	freopen("000.in", "r", stdin);
//	freopen(".out", "w", stdout);
#endif
	while(~scanf("%d%d%d", &num[0], &num[1], &num[2])&&(num[0]+num[1]+num[2])) {
		int P = num[0] + 2*num[1] + 5*num[2];
		memset(c1, 0, sizeof(c1));
		for(int i = 0; i <= num[0]; i++) {
			c1[i] = 1;
		}//对于只有1元硬币,从0元到num[0]元,每种价值的方案数都是1
		for(int i = 1; i < 3; i++) {
			memset(c2, 0, sizeof(c2));
			for(int j = 0; j <= num[i] && j*v[i] <= P; j++) {
				for(int k = 0; k + j*v[i] <= P; k++) {
					c2[k + j*v[i]] += c1[k];
				}
			}
			memcpy(c1, c2, sizeof(c1));
		}
		int ans = 0;
		for(int i = 0; i <= P + 1; i++) if(!c1[i]) {
			ans = i;
			break;
		}
		printf("%d\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值