FatMouse' Trade
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
Sample Output
13.333 31.500
————————————————————尴尬的分割线————————————————————
思路:贪心水题。按照性价比排个序,没钱了就break。
代码如下:
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <iostream>
using namespace std;
/****************************************/
struct Node
{
int get, give;
double val;
}a[10010];
int cmp(const void* a, const void* b)
{
return (*(Node *)b).val > (*(Node *)a).val ? 1 : -1;
}
int main()
{
int money, node;
while(~scanf("%d%d", &money, &node)) {
if(money == -1 && node == -1)
break;
for(int i = 0; i < node; i++) {
scanf("%d%d", &a[i].get, &a[i].give);
a[i].val = (double)a[i].get / a[i].give;
}
qsort(a, node, sizeof(a[0]), cmp);
double ans = 0;
int i = 0;
for(i = 0; i < node; i++) {
if(money < a[i].give) {
ans += (double)money * a[i].val;
break;
}
else {
ans += a[i].get;
money -= a[i].give;
}
}
printf("%.3lf\n", ans);
}
return 0;
}