【01背包方案数】POJ-3132 Sum of Different Primes

69 篇文章 0 订阅
12 篇文章 0 订阅
Sum of Different Primes
Time Limit: 5000MS Memory Limit: 65536K
   

Description

A positive integer may be expressed as a sum of different prime numbers (primes), in one way or another. Given two positive integers n and k, you should count the number of ways to express n as a sum of k different primes. Here, two ways are considered to be the same if they sum up the same set of the primes. For example, 8 can be expressed as 3 + 5 and 5 + 3 but the are not distinguished.

When n and k are 24 and 3 respectively, the answer is two because there are two sets {2, 3, 19} and {2, 5, 17} whose sums are equal to 24. There are not other sets of three primes that sum up to 24. For n = 24 and k = 2, the answer is three, because there are three sets {5, 19}, {7, 17} and {11, 13}. For n = 2 and k = 1, the answer is one, because there is only one set {2} whose sum is 2. For n = 1 and k = 1, the answer is zero. As 1 is not a prime, you shouldn’t count {1}. For n = 4 and k = 2, the answer is zero, because there are no sets of two different primes whose sums are 4.

Your job is to write a program that reports the number of such ways for the given n and k.

Input

The input is a sequence of datasets followed by a line containing two zeros separated by a space. A dataset is a line containing two positive integers n and k separated by a space. You may assume that n ≤ 1120 and k ≤ 14.

Output

The output should be composed of lines, each corresponding to an input dataset. An output line should contain one non-negative integer indicating the number of the ways for n and k specified in the corresponding dataset. You may assume that it is less than 231.

Sample Input

24 3 
24 2 
2 1 
1 1 
4 2 
18 3 
17 1 
17 3 
17 4 
100 5 
1000 10 
1120 14 
0 0

Sample Output

2 
3 
1 
0 
0 
2 
1 
0 
1 
55 
200102899 
2079324314
————————————————————平凡の分割線————————————————————
思路:将一个数分成k个不同的素数的和。
首先打素数表,然后素数就是01背包问题。
被拆分的数字大小就是背包容量。
除了容量限制,背包还有一个物品个数的限制。
给出两种解法:DP、母函数
以下四种DP方式都对:
【一】
for(int k = 0; k < cnt && p[k] <= v; k++) {
	for(int j = v; j >= p[k]; j--) {
		for(int i = 1; i <= n; i++) {
			dp[j][i] += dp[j-p[k]][i-1];
		}
	}
}

【二】

for(int k = 0; k < cnt && p[k] <= v; k++) {
	for(int i = n; i >= 1; i--) {
		for(int j = p[k]; j <= n; j++) {
			dp[j][i] += dp[j-p[k]][i-1];
		}
	}
}

【三】

for(int k = 0; k < cnt && p[k] <= v; k++) {
	for(int j = v; j >= p[k]; j--) {
		for(int i = n; i >= 1; i--) {
			dp[j][i] += dp[j-p[k]][i-1];
		}	
	}
}
【四】
for(int k = 0; k < cnt && p[k] <= v; k++) {
	for(int i = n; i >= 1; i--) {
		for(int j = v; j >= p[k]; j--) {
			dp[j][i] += dp[j-p[k]][i-1];
		}
	}
}

原因分析:根据状态转移方程,dp[j][i] += dp[j-p[k]][i-1],只要我们在更新dp[j][i]之前没有更新dp[j-p[k]][i-1],就没有后效性。通过i、j作出坐标系,根据更新的顺序划线,就可以很容易地发现这件事。
下面给出方式【一】的图:

代码如下:
/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <climits>
#include <iostream>
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
/****************************************/
const int N = 1200;
bool vis[N];
int p[N], dp[1200][20];

int get_prime() {
    int cnt = 0;
    vis[1] = 1;
    for(int i = 2; i < N; i++) {
        if(!vis[i]) p[cnt++] = i;
        for(int j = 0; j < cnt && p[j]*i < N; j++) {
            vis[p[j]*i] = 1;
            if(i % p[j] == 0) break;
        }
    }
	return cnt;
}

int main()
{
#ifdef J_Sure
	freopen("000.in", "r", stdin);
	freopen("999.out", "w", stdout);
#endif
	memset(vis, 0, sizeof(vis));
	int cnt = get_prime();
	int v, n;
	while(scanf("%d%d", &v, &n), v||n) {
		memset(dp, 0, sizeof(dp));
		dp[0][0] = 1;
		for(int k = 0; k < cnt && p[k] <= v; k++) {
			for(int j = v; j >= p[k]; j--) {
				for(int i = n; i >= 1; i--) {
					dp[j][i] += dp[j-p[k]][i-1];
				}
			}
		}
		printf("%d\n", dp[v][n]);
	}
	return 0;
}

下面给出母函数的解法:
P.S. 由于是01背包,只需要在 j 的循环中,上下限设置为0到1即可。
代码如下:
/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <climits>
#include <iostream>
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
/****************************************/
const int N = 1120, M = 14;
bool vis[N+5];
int p[N+5], c1[N+5][M+5], c2[N+5][M+5];

int get_prime() {
    int cnt = 0;
    vis[1] = 1;
    for(int i = 2; i < N+5; i++) {
        if(!vis[i]) p[cnt++] = i;
        for(int j = 0; j < cnt && p[j]*i < N+5; j++) {
            vis[p[j]*i] = 1;
            if(i % p[j] == 0) break;
        }
    }
	return cnt;
}


int main()
{
#ifdef J_Sure
	freopen("000.in", "r", stdin);
	freopen("999.out", "w", stdout);
#endif
	memset(vis, 0, sizeof(vis));
	int cnt = get_prime();
	memset(c1, 0, sizeof(c1));
	c1[0][0] = 1;
	for(int i = 0; i < cnt; i++) {
		memset(c2, 0, sizeof(c2));
		for(int j = 0; j <= 1 && j*p[i] <= N; j++) {
			for(int k = 0; k + j*p[i] <= N; k++) {
				for(int l = 0; l + j <= M; l++) {
					c2[k+j*p[i]][l+j] += c1[k][l];
				}
			}
		}
		memcpy(c1, c2, sizeof(c1));
	}
	int x, y;
	while(scanf("%d%d", &x, &y), x||y) {
		printf("%d\n", c1[x][y]);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值