【记忆化搜索】HDU-1501 Zipper

Zipper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

 

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 

Sample Input
  
  
3 cat tree tcraete cat tree catrtee cat tree cttaree
 

Sample Output
  
  
Data set 1: yes Data set 2: yes Data set 3: no
 
————————————————————————————————————————————————————————
题意:给出三个字串,问第三个字串能否由前两个字串拼凑而成。顺序不能打乱。
思路:一脸DFS的样子。但是需要记忆化。
为什么要记忆化呢?
首先我们是c串一直匹配到最后的时候才得到ok = true的,之后回溯的过程中一旦ok = true也就直接return了(剪枝)。那么如果ok = false,就算是搜索过的状态,也会再重新搜索一遍。
为什么会有搜索过的状态?假如a串和b串的开头类似,都为字符x,假设a串的x先用完,一定会回溯调整a串和b串贡献给c串的x的个数。在这之后,还会有a串x用完并且b串用掉的字符个数一致的时候。然而这个状态已经搜索过了。
参考一个例子:aaabb  aaaaaacd aaaaaacaaabbd
代码如下:
/**
 * ID: j.sure.1
 * PROG:
 * LANG: C++
 */
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <climits>
#include <iostream>
#define For(i, x, y) for(int i=x; i<y; i++)
#define For_(i, x, y) for(int i=x; i>=y; i--)
#define Mem(f, x) memset(f, x, sizeof(f))
#define Sca(x) scanf("%d", &x)
#define Pri(x) printf("%d\n", x)
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
/****************************************/
const int N = 222;
char a[N], b[N], c[N<<1];
bool vis[N][N];
int n;
bool ok;

void dfs(int u, int ai, int bi)
{
    if(u == n) {
        ok = true;
        return ;
    }
    if(ok||vis[ai][bi]) return ;
    vis[ai][bi] = true;
    if(c[u] != a[ai] && c[u] != b[bi]) {
        return ;
    }
    if(c[u] == a[ai])
        dfs(u+1, ai+1, bi);
    if(c[u] == b[bi])
        dfs(u+1, ai, bi+1);
}

int main()
{
#ifdef J_Sure
    freopen("000.in", "r", stdin);
    freopen("999.out", "w", stdout);
#endif
    int T, kase = 1;
    Sca(T);
    while(T--) {
        scanf("%s%s%s", a, b, c);
        Mem(vis, 0);
        n = strlen(c);
        ok = false;
        dfs(0, 0, 0);
        printf("Data set %d: %s\n", kase++, ok ? "yes" : "no");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值