【连通图|桥】ZOJ-2588 Burning Bridges

19 篇文章 0 订阅
14 篇文章 0 订阅

Burning Bridges

Time Limit: 5 Seconds       Memory Limit: 32768 KB

Ferry Kingdom is a nice little country located on N islands that are connected by M bridges. All bridges are very beautiful and are loved by everyone in the kingdom. Of course, the system of bridges is designed in such a way that one can get from any island to any other one.

But recently the great sorrow has come to the kingdom. Ferry Kingdom was conquered by the armies of the great warrior Jordan and he has decided to burn all the bridges that connected the islands. This was a very cruel decision, but the wizards of Jordan have advised him no to do so, because after that his own armies would not be able to get from one island to another. So Jordan decided to burn as many bridges as possible so that is was still possible for his armies to get from any island to any other one.

Now the poor people of Ferry Kingdom wonder what bridges will be burned. Of course, they cannot learn that, because the list of bridges to be burned is kept in great secret. However, one old man said that you can help them to find the set of bridges that certainly will not be burned.

So they came to you and asked for help. Can you do that?


Input

The input contains multiple test cases. The first line of the input is a single integer T (1 <= T <= 20) which is the number of test cases. T test cases follow, each preceded by a single blank line.

The first line of each case contains N and M - the number of islands and bridges in Ferry Kingdom respectively (2 <= N <= 10 000, 1 <= M <= 100 000). Next M lines contain two different integer numbers each and describe bridges. Note that there can be several bridges between a pair of islands.


Output

On the first line of each case print K - the number of bridges that will certainly not be burned. On the second line print K integers - the numbers of these bridges. Bridges are numbered starting from one, as they are given in the input.

Two consecutive cases should be separated by a single blank line. No blank line should be produced after the last test case.


Sample Input

2

6 7
1 2
2 3
2 4
5 4
1 3
4 5
3 6

10 16
2 6
3 7
6 5
5 9
5 4
1 2
9 8
6 4
2 10
3 8
7 9
1 4
2 4
10 5
1 6
6 10

Sample Output

2
3 7

1
4 
————————————————————————————————————————————————————————————————————————————————————————————————
题意:给出一个允许有重边的无向图,求出其中的桥并输出。(桥按照输入顺序进行编号)
思路:除了基本的求桥之外,还有一点要注意,如果u,v之间有重边,那么u,v之间的任意一条边都不是桥。因为点太多而且有重边,因此重边的标记必须打在邻接表中,在每一次加入新边之前,遍历u的边,如果发现了v,那么做标记,取消加边操作。
P.S. 这道题的输出需要格外注意,因为严格要求仅输出的桥之间有空格,而枚举的时候不知道哪个是最后一个桥,如果采用了先输出空格这种方式,要注意假如一个桥都没有,不要输出回车换行。(弄了我5、6个PE)
代码如下:
/*
 * ID: j.sure.1
 * PROG:
 * LANG: C++
 */
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <climits>
#include <iostream>
#define Mem(f, x) memset(f, x, sizeof(f))
#define PB push_back
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
const double eps = 1e-8;
/****************************************/
const int N = 1e4+5, M = 2e5+5;
struct Edge {
    int v, next, idx, tag;
    Edge(){}
    Edge(int _v, int _next, int _idx, int _tag = 0):
        v(_v), next(_next), idx(_idx), tag(_tag){}
}e[M];
int n, m, deep, tot, bri;
int dfn[N], head[N];
bool isbri[M];

void __init__()
{
    Mem(head, -1);
    Mem(isbri, 0);
    Mem(dfn, 0);
    tot = deep = bri = 0;
}

void add(int u, int v, int idx)
{
    int p;
    for(p = head[u]; ~p; p = e[p].next) {
        if(e[p].v == v) {
            e[p].tag++;
            return ;
        }
    }
    e[tot] = Edge(v, head[u], idx);
    head[u] = tot++;
}

int dfs(int u, int fa)
{
    int lowu = dfn[u] = ++deep;
    for(int i = head[u]; ~i; i = e[i].next) {
        int v = e[i].v;
        if(!dfn[v]) {
            int lowv = dfs(v, u);
            lowu = min(lowu, lowv);
            if(lowv > dfn[u] && !e[i].tag) {
                isbri[e[i].idx] = 1;
                bri++;
            }
        }
        else if(dfn[v] < dfn[u] && v != fa)
            lowu = min(lowu, dfn[v]);
    }
    return lowu;
}

int main()
{
#ifdef J_Sure
    freopen("000.in", "r", stdin);
    //freopen("999.out", "w", stdout);
#endif
    int T;
    scanf("%d", &T);
    while(T--) {
        __init__();
        scanf("%d%d", &n, &m);
        int u, v, ID = 0;
        for(int i = 0; i < m; i++) {
            scanf("%d%d", &u, &v);
            u--; v--;
            add(u, v, ID);
            add(v, u, ID++);
        }
        dfs(0, -1);
        printf("%d\n", bri);
        bool fir = false;
        for(int j = 0; j < m; j++) {
            if(isbri[j]) {
                if(fir) putchar(' ');
                printf("%d", j+1);
                fir = true;
            }
        }
        if(fir) puts("");
        if(T) puts("");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值