hdu 3555 数位dp模板题

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 5529    Accepted Submission(s): 1912


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU


与上一题一样,数位dp模板。

代码:

/* ***********************************************
Author :xianxingwuguan
Created Time :2014-2-7 2:38:12
File Name :1.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef __int64 ll;
ll num[22],dp[22][3];
ll dfs(ll pos,ll st,bool flag){
	if(pos==0)return st==2;
	if(flag&&dp[pos][st]!=-1)return dp[pos][st];
	ll ans=0;
	ll u=flag?9:num[pos];
	for(ll d=0;d<=u;d++){
		if(st==2||(st==1&&d==9))ans+=dfs(pos-1,2,flag||d<u);
		else if(d==4)ans+=dfs(pos-1,1,flag||d<u);
		else ans+=dfs(pos-1,0,flag||d<u);
	}
	if(flag)dp[pos][st]=ans;
	return ans;
}
ll solve(ll x){
	ll len=0;
	memset(dp,-1,sizeof(dp));
	while(x){
		num[++len]=x%10;
		x/=10;
	}
	return dfs(len,0,0);
}
int main(){
       ll T,i,j,k,m,n;
       scanf("%I64d",&T);
       while(T--){
              scanf("%I64d",&n);
              printf("%I64d\n",solve(n));
       }
       return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值