hdu 2815 大步小步

Mod Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4105    Accepted Submission(s): 1068


Problem Description

  The picture indicates a tree, every node has 2 children.
  The depth of the nodes whose color is blue is 3; the depth of the node whose color is pink is 0.
  Now out problem is so easy, give you a tree that every nodes have K children, you are expected to calculate the minimize depth D so that the number of nodes whose depth is D equals to N after mod P.
 

Input
The input consists of several test cases.
Every cases have only three integers indicating K, P, N. (1<=K, P, N<=10^9)
 

Output
The minimize D.
If you can’t find such D, just output “Orz,I can’t find D!”
 

Sample Input
  
  
3 78992 453 4 1314520 65536 5 1234 67
 

Sample Output
  
  
Orz,I can’t find D! 8 20
 

Author
AekdyCoin
 

基本是测试模板。

代码:

/* ***********************************************
Author :rabbit
Created Time :2014/4/2 21:01:29
File Name :7.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
class HASH{    
    public:    
        struct node{    
            ll next,first,second;
		    node(int next=0,int first=0,int second=0):next(next),first(first),second(second){}	
        }edge[140000];    
        ll tol,head[140100];    
        void clear(){    
            memset(head,-1,sizeof(head));tol=0;    
        }    
        void add(ll x,ll y){    
            if(find(x)!=-1)return;  
            ll t=x%65535;    
            edge[tol]=node(head[t],x,y);
            head[t]=tol++;    
        }    
        ll find(ll x){    
            ll t=x%65535;    
            for(ll i=head[t];i!=-1;i=edge[i].next)    
                if(edge[i].first==x)return edge[i].second;    
            return -1;    
        }    
}mi;    
ll gcd(ll a,ll b) { return b==0?a:gcd(b,a%b); }  
ll ext_gcd(ll a,ll b,ll &x,ll &y)  {  
    if(b==0){x=1,y=0;return a;}  
    ll d=ext_gcd(b,a%b,y,x);y-=a/b*x;  
    return d;  
}  
ll pow_mod(ll a,ll n,ll m){  
    ll res=1;a%=m;  
    while(n){  
        if(n&1) res=res*a%m;  
        a=a*a%m;  n>>=1;  
    }  
    return res;  
}  
ll BabyStep_GiantStep(ll A,ll B,ll C){  
    B%=C;ll tmp=1;mi.clear();  
    for(int i=0;i<=100;++i){  
        if(tmp==B%C) return i;  
        tmp=tmp*A%C;  
    }  
    ll D=1,d=0;  
    while((tmp=gcd(A,C))!=1){  
        if(B%tmp) return -1;  
        C/=tmp;B/=tmp;D=D*A/tmp%C;d++;  
    }  
    ll m=(ll)ceil(sqrt((double)C));tmp=1;  
    for(int i=0;i<=m;++i){  
        mi.add(tmp,i);  
        tmp=tmp*A%C;  
    }  
    ll x,y,K=pow_mod(A,m,C);  
    for(int i=0;i<=m;++i){  
        ext_gcd(D,C,x,y);  
        tmp=((B*x)%C+C)%C;  
        if((y=mi.find(tmp))!=-1)return i*m+y+d;  
        D=D*K%C;  
    }  
    return -1;  
}  
int main(){
    ll A, B, C;
    while( scanf("%I64d%I64d%I64d",&A,&C,&B ) !=EOF ){
        if(B>C) {printf("Orz,I can’t find D!\n");continue;}
        ll tmp = BabyStep_GiantStep ( A, B, C );
        if ( tmp == -1 )puts("Orz,I can’t find D!");
        else printf("%I64d\n",tmp);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值