hdu 3625 第一类斯特灵数

Examining the Rooms

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 971    Accepted Submission(s): 576


Problem Description
A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap! You know that there is exactly one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and the key for Room 1 is numbered Key 1, the key for Room 2 is Key 2, etc.
To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force, then repeat the procedure above, until all the rooms are examined.
Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You want to know what is the possibility of that you can examine all the rooms finally.
 

Input
The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)
 

Output
Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.
 

Sample Input
  
  
3 3 1 3 2 4 2
 

Sample Output
 
 
0.3333 0.6667 0.6250
Hint
Sample Explanation When N = 3, there are 6 possible distributions of keys: Room 1 Room 2 Room 3 Destroy Times #1 Key 1 Key 2 Key 3 Impossible #2 Key 1 Key 3 Key 2 Impossible #3 Key 2 Key 1 Key 3 Two #4 Key 3 Key 2 Key 1 Two #5 Key 2 Key 3 Key 1 One #6 Key 3 Key 1 Key 2 One In the first two distributions, because Key 1 is locked in Room 1 itself and you can’t destroy Room 1, it is impossible to open Room 1. In the third and forth distributions, you have to destroy Room 2 and 3 both. In the last two distributions, you only need to destroy one of Room 2 or Room


有n个房间,n把钥匙,每个房间放置一把钥匙,现在要访问完所有的房间,只允许打破k个房间的门,问有多大的概率可以访问完所有的房间,房间1的门不能被打破。

思路:N个房间形成[1,K]个环时可以。N个元素形成K个环为第一类斯特灵数S[N][K]=S[N-1][K-1]+S[N-1][K]*(N-1)。题目要求不能炸第一个房间,要减去第一个房间独立成环的情况,答案为sigama(S[n][i]-S[n-1][i-1])(1<=i<=K)。

代码:

/* ***********************************************
Author :rabbit
Created Time :2014/4/4 9:02:18
File Name :E.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef __int64 ll;
ll f[30],S[30][30];
int main()
{
     //freopen("data.in","r",stdin);
     //freopen("data.out","w",stdout);
     f[0]=1;for(ll i=1;i<=20;i++)f[i]=f[i-1]*i;
	 for(ll i=1;i<=20;i++){
		 S[i][0]=0;S[i][i]=1;
		 for(ll j=1;j<i;j++)
			 S[i][j]=(i-1)*S[i-1][j]+S[i-1][j-1];
	 }
	 int T;
	 scanf("%d",&T);
	 while(T--){
		 ll n,m;
		 scanf("%I64d%I64d",&n,&m);
		 if(n==1||m==0){
			 puts("0.0000");continue;
		 }
		 double ans=0;
		 for(ll i=1;i<=m;i++)ans+=S[n][i]-S[n-1][i-1];
		 ans/=f[n];
		 printf("%.4lf\n",ans);
	 }
     return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值