hdu 3723 卡特兰数

Delta Wave

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 690    Accepted Submission(s): 223


Problem Description
A delta wave is a high amplitude brain wave in humans with a frequency of 1 – 4 hertz which can be recorded with an electroencephalogram (EEG) and is usually associated with slow-wave sleep (SWS).
-- from Wikipedia

The researchers have discovered a new kind of species called "otaku", whose brain waves are rather strange. The delta wave of an otaku's brain can be approximated by a polygonal line in the 2D coordinate system. The line is a route from point (0, 0) to (N, 0), and it is allowed to move only to the right (up, down or straight) at every step. And during the whole moving, it is not allowed to dip below the y = 0 axis.

For example, there are the 9 kinds of delta waves for N = 4:





Given N, you are requested to find out how many kinds of different delta waves of otaku.
 

Input
There are no more than 20 test cases. There is only one line for each case, containing an integer N (2 < N <= 10000)

 

Output
Output one line for each test case. For the answer may be quite huge, you need only output the answer module 10 100.
 

Sample Input
  
  
3 4
 

Sample Output
  
  
4 9
 

Source


卡塔兰数。c[n] = 2n! / ((n+1)! n!) =  c(2n, n) / (n + 1)
因为始点与终点是水平的。 所以向上多少,向下就要多少,其余的都是水平前景的。
假设 上升了 k 次  那就必须下降 k 次   所以 a[k] = c(n, 2k) * c(2k, k) / (k + 1);
k 是从 0 变化到 n / 2的;
那么sum[n] = a[0] + a[1] + a[2] + ……+ a[k] (k <= n/2);  且a[0] = 1;(只有一个水平的).
但是如果对于每个 a[k]  都用阶乘是会超时的。
所以用数列公司 a[k] = c(n, 2k) * c(2k, k) / (k + 1)     与  a[k - 1] = c(n, 2k - 2) * c(2k - 2, k - 1) / k
递推出

a[k] = a[k-1] * (n - 2 * k + 1) * (n - 2 * k + 2) / (k * (k + 1));

由于数据比较大,所以采用java实现比较方便。

代码:

import java.util.*;
import java.math.*;
import java.io.*;
public class Main {
    public static void main(String[] args) {
        Scanner input = new Scanner(System.in);
        BigInteger sum,t;
        while (input.hasNext()) {
            int n = input.nextInt();
            sum = t = BigInteger.ONE;
            for (int k = 1; k <= n / 2; k++) {
                t = t.multiply(BigInteger.valueOf((n - 2 * k + 1) * (n - 2 * k + 2))).divide(BigInteger.valueOf(k * (k + 1)));
                sum = sum.add(t);
            }
            System.out.println(sum.mod(BigInteger.TEN.pow(100)));
        }
    }
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值