NYOJ 1112 求次数 (map)

描述 

http://acm.nyist.net/JudgeOnline/problem.php?pid=1112

题意很简单,给一个数n 以及一个字符串str,区间【i,i+n-1】 为一个新的字符串,i 属于【0,strlen(str)】如果新的字符串出现过ans++,例如:acmacm n=3,那么 子串为acm cma mac acm ,只有acm出现过

求ans;

输入
LINE 1: T组数据(T<10)
LINE 2: n ,n <= 10,且小于strlen(str);
LINE 3:str
str 仅包含英文小写字母 ,切长度小于10w
输出
求 ans
样例输入
2
2
aaaaaaa
3
acmacm
样例输出
5
1

分析:

map问题,主要是自己方式。见代码。


AC代码:

 
#include<iostream>
#include<fstream>
#include<string>
#include<cstdio>
#include<map>
using namespace std;
ifstream fin("input.txt");
ofstream fout("output.txt");
#define fin cin
#define fout cout
int main()
{
    int t,n;
    string s;
    //cin>>t;
    scanf("%d",&t);
    while(t--){
        cin>>n>>s;
        int len=s.length(),ans=0;
        map<string,int> snum;
        string ss;
        for(int i=0;i<s.length()-n+1;i++){
            ss=s.substr(i,n);
            if(snum[ss]==1) ans++;
            else snum[ss]=1;
        }
        cout<<ans<<endl;
    }
    return 0;
}
        



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值